Foscam FI9805w
  • Hi, I'm testing SecuritySpy and I have a problem with my cameras FI9805w.
    Every 15-20 minutes, due to a green screen that lasts a few frames, it enables the motion detect. I tested the network and it is ok. I lowered the frame rate but the problem remains. Tried other software without any errors. May depend on what? I've also updated the firmware of the cameras and in SecuritySpy set as manual and how foscam 9802. The needed results does not change.

    LOG:

    10.22.2013 1115 -54: Error communicating with the network device "Network camera 4" 3.1.2,551122,801 Data from network device not as expected

    10.22.2013 1115 -59: Error communicating with the network device "Network camera 4" 3.1.2,80210,999
  • Hi,

    The FI9805W isn't yet on our compatible camera list because we haven't fully tested it. However there is no reason why it shouldn't work in SecuritySpy.

    A green screen indicates that something went wrong with the H.264 video decompression. This could point to a network problem (if the network is too slow, data may get lost), or it could point to a camera problem (the camera itself producing bad data). I would normally suggest checking the network and updating the camera's firmware but it sounds like you've already done these things.

    As for the two errors you mention, the first one relates to some bad data in the H.264 stream, and the second relates to a bad RTSP reply from the camera.

    The camera specs mention that they work in MJPEG mode - this may be more reliable so it's something to test. Try the "Foscam JEPG" profile in SecuritySpy. Does this work?
  • I am trying to test security spy with an FI9805E and I'm not able to receive video at all regardless if which Focsam profile I choose. I know it isn't on your list of compatible cameras yet but as you said above, don't see any reason why it shouldn't function. Any advice would be welcome
  • You can use for Video Device Settings:

    Device Type: Manual configuration
    Address: xxx.xxx.x.xxx
    HTTP port: xx
    Username: [username]
    Password: [password]
    Format: HTTP (video only)
    Request:
    /cgi-bin/CGIProxy.fcgi?cmd=snapPicture2&usr=[USERNAME]&pwd=[PASSWORD]


    Hope dr.Ben will have real support soon!

  • Hi Sasha, yes we have seen this working with other Foscam cameras but haven't confirmed it for this one, it would be good to get confirmation that this works.

    Otherwise, the existing FI9821W profile in SecuritySpy may work for the FI9805E camera. We don't officially support the FI9821W because there are still some problems with it (going offline after a day or so and requiring a restart), however the profile is still there in the software and does work to pull in the video stream. Can someone please try this and confirm?

    fabietto - would you be able to put your camera online temporarily for us to test? Please email us if this is possible, we can give you instructions. Thanks.
  • I have a FI9805W set up and working with SS. I am using the Foscam FI9802W, FI9821W profile in SS. I did set the camera video settings itself to 512K bit rate and 10 for Frame Rate and Key Frame rate. I've since been tweaking my wireless network and hope to be able to increase the bit rate... I probably could now but just have too many automation projects going on and its working. This camera has other streams you could chose from to get VGA level but I'm using the stream 0 and getting the picture at 720P. Ben if you want to play with my camera and see what else you can learn about it just let me know.

    I also have a FI9821W camera installed..... can you give us more info on this restart problem... it has been working for me... but I found today that it had gone from Active to Passive and I had to restart SS then to get it to go back to Active state.... Until I restarted SS I could not get it to go back to active.
  • One other thing on the FI9805W.... When you configure it in SS Video Device settings you need to make sure you set the Format to H.264 RTSP...... I left the HTTP and RTSP port values blank... SS uses the right ones on its own.. Of course you have to give it a valid userid and password to access the camera as well.
  • Great to hear that the FI9805W works with the existing FI9821W profile. And yes your advice about using the H.264 RTSP format (not the JPEG HTTP format) is the way to go.

    We've had many users report that after a day or two their FI9821W cameras stop responding and the only solution is to restart the camera. This is the only reason why the camera is not currently on our list and therefore not officially supported. Have you experienced this?
  • I have not had to restart the FI9821W camera. I have had to restart SS though a couple of times just to get it to let me put the camera back into active mode so I could capture video. But that was just in the last couple of days and before that it ran solidly ever since I set the bit rates and frame rates lower, but I think that is a network issue that can be solved.
  • Yes it could be a network problem. Also make sure you are using the latest version of SecuritySpy (3.1.3) as this may resolve the issue.
  • When I installed 3.1.3 that is when I started seeing some issues... 3.1.2 had no problems with these cameras but as you know 3.1.2 had some issues with the older Foscam MJPEG cameras. These cameras have not yet received a firmware update with the less than stellar "new and improved" security that Foscam rolled out on the older cameras. I was thinking about looking and seeing if I had a copy of 3.1.2 still and go back to that and see if it makes the issues go away.... When I installed 3.1.3 on the machine where I have my license resulted in my video files for that day only being deleted.... but since then the only issue I have seen is the day where I could not get it to go in active mode on the FI9821W camera ( which was the only one I was trying to make active ). Restarting SS then let me put it back in active... I had some more issues and since I was using an external USB drive on this old Mac to store the video I then reset the location and let it dump it for now to the heard drive on the Mac... I haven't seen any more problems with losing the ability to stay active on the camera in a day now.... Still don't understand that one as I have the mac set not to put any drives to sleep and that is the only thing running on this old 2006 iMac is SS. I'm moving SS soon to a Mac Mini so this machine is only temporary.
  • the new F19831W's are doing the same. green screen all the time. Nothing wrong with the network as all other cameras are working without a hitch.
    Using 3.1.3. If you only have the foscams running, security spy freezes every 2.5 days ( 10.9 )
  • I do not have green screen issues... once I set my bit and frame rates as I described above that eliminated that. I'm running it on OS X 10.7. So far its been solid for a little over a day after I moved the location of the captured files. When I had green screen I would see the cameras fine in Safari, but SS seemed to have some problems with the streams and I would see a lot of green. If I get the time I am going to start moving the bit rate higher and see if it comes back.
  • Anyone get the FI9805E working consistently? I continue to have green screen in SS but the Foscam browser works fine. Running SS 3.1.2
    Any insight is appreciated. Not a network issue as there are multiple other cameras all working fine. Missed my return window with Amazon by a day... Now I really want to get this camera working.
  • Is this about the 805E or 805W ? I've been playing around with the 805W and as noted above I got it to "work" by cutting down the bit rate to 512K and also lowering the frame route down. I wasn't really happy with it though... so I experimented and got an older Apple Airport Express wifi router... set it up to connect to my wifi network ( not extend the network... just connect to it ) and then hooked up the camera to the Airport Express via an ethernet cable. So I basically remained a wifi camera but I dumped using the wifi radio in the Foscam. I still have the camera assigned a fixed ip address.... The AE gets its own wifi address via DHCP. With this setup I have since bumped up the bit rate to 2M and the frame rate to 26 FPS. It's been rock solid since... no green screen. I'm going to go ahead and crank the bit rate to 4M today and see how that goes, but I'm happy with the 2M rate I have now.

    I've also tried this with a FI9821W V2 but with not as good results. I'm going to try it again later this week with a new Airport Express that supports the 5ghz band and see if moving the camera over to that and bypassing its wifi radios will improve it as well.... if not then I will dump the 9821W and buy a better camera that has pan and tilt.

    This type of solution absolutely negates any cost savings of the Foscam line.. but if you have them and can't return them then its one way to make them useable. I got the older 802.11 B/G/N style Airport Express on eBay for less than $50 and it was new in the box...
  • That's very interesting information doodah. What I think is happening with this green screen issue is this: the camera will have a fixed-size network buffer that collects data to be sent over the network. When this buffer fills up, the camera has a problem because data is being sent at a slower rate than it is being created. The best thing that cameras can do in this situation is to finish sending the current frame, and wait until some buffer space becomes available before starting to send the next fame. This will result in a lower frame rate but no video corruption. However, what I think is occurring with this camera is that it simply drops the rest of the current frame, resulting in only partial data being sent, resulting in the green image.

    From doodah's information above, it seems there may be a problem with the camera's WiFi connection that is causing slow data rates, which therefore results in the green image. So there appear to be three solutions:

    - Use a WiFi bridge device to bypass the camera's WiFi hardware, as described by doodah above
    - Connect the camera by wired ethernet, not WiFi
    - Significantly lower the data rate and frame rate in the camera.
  • I, too, am currently evaluating SecuritySpy 3.2 and am using four Foscam FI9805E (the POE version) cameras, along with an Axis panoramic POE camera. All of the cameras are directly connected via CAT6 to a gigabit switch which in turn is connected directly (via ethernet) to a 2009 Mac Mini that I am running SecuritySpy on with OS X 10.8. The house is a brand new construction, so the wiring should be solid. I am running the FI9805E cameras on the latest firmware that supports ONVIF (System firmware 1.4.1.8 and Application firmware 1.14.1.18).

    Every 5-10 seconds, on these cameras, I get a frame or two of green. Obviously, this makes motion detection impossible without a flood of recordings/emails. I do not see the same green frames in Live Cams Pro which I use on my iOS devices to view the cameras, nor do I see them when viewing via the Foscam web servers/plugins directly. I've also been evaluating Sighthound, which does motion/human detection and seems to work fine (though that software does not have all the features/flexibility I want from SecuritySpy).

    I have tried bringing down the frame rate and key frame values on the camera setting to 15, rather than 30, but I still see just as many green screens. I don't doubt that the camera may be sending bad data in the RTSP stream, but I'm puzzled why I don't see it with other software. Is there anything that can be done when you receive a bad packet like that (ignore it, or don't try to blit it)? Something that would allow the motion detection to still work reliably? These cameras have great promise - high resolution and IR mode at a pretty low cost, compared to other makes (like Axis). The motion detection on my Axis indoor dome camera is flawless and is the reason I'm still stuck on trying to get it to work with my Foscam cameras too.

    Any thoughts Ben? Or have others found any solutions to this issue?
  • We too see frequent green screens on four FI9805W cameras using the profile for the Foscam FI9802/FI9821. We've dropped the streams down to 512K and set the bitrate=10 and framerate=10 just to see if we can eliminate the green screen. We have a separate Access Point set up for the cameras.

    We do not ever see a Green (or black) screen using an iOS app named LiveCams, even over WAN, so I don't think it's a WIFI issue, unless the LiveCams app is discarding bad packets and/or the green screen when it occurs.

    We seem to have better results with SecuritySpy when using the manual HTTP only method as SASHA mentions above.

    Any other ideas or suggestions ?

    Peter
  • And I should have mentioned that we are using the latest Foscam Firmware, v1.4.1.7 and App Firmware v1.14.1.21
  • I've seen that with other apps not showing a "green screen"... but I think its that they are just tossing the bad packets... if you watch really closely and have the timestamp being shown on the frame from the camera itself you will see some anomalies that tell you that packets have been dropped... Either that or my time / space continuum is jumping ahead very now and then a few seconds. So either SS would have to have some sort of selectable option to let us "ignore" those packets or we all need to buy better cameras.. :-) I thought I had rid myself of this problem via a access point providing the network connection and bypassing the camera's wifi radios... it does make it better.. but it really doesn't solve the problem reliably.
  • I posted this in error yesterday to a thread for the 8905; I meant to post about the 9805W:

    Foscam has released new firmware for the FI9805W, v2.14.1.5 the update includes an update for ONVIF.

    I loaded it into my camera and the improvements are remarkable. ONVIF is now working very well, I get 30fps, near realtime stream, very few if any dropped packets or green screen. I'm running a 512 bitrate and 30fps over wifi

    Here's a Link to Their Firmware page For All Models
  • This ONVIF functionality didn't last too long. Many "green screens". I'm now trying manual settings as listed below. Hopefully others can test too.

    image
  • Are you running wireless or do you have ethernet cable attached? I am in process of moving stuff around with my setups... but with WiFi the best I got from it was when I actually did not use Foscam wifi ... I put a access point to my wifi with the camera and ran the ethernet cable to the camera from the access point. Even with the latest firmware updates the Foscam WiFi leaves much to be desired. I have seen a lot of questions about why it doesn't show dropped frames when accessing their camera directly via a web browser, but if you watch carefully you will see thats just because the way their web interface doesn't transmit the corrupted packets to the browser... If you have a camera that has its own time built into the video screen like their H.264 cameras then you if watch carefully you can see the time not be very smooth and consistent. Also if you have people walking through the camera field of vision sometimes you can detect the jerky loss of frames in their motion. I think the only hope with their cameras is either with an Access Point actually doing the WiFi or you have an ethernet cable.... Once you factor in the cost of a decent WiFi Access Point ( I'm using Apple Airport Express routers as my AP ) then there is zero reason to invest in Foscam. I will use these until they die and then move on to something more robust. I must say that its been interesting learning about cameras... you get to learn a lot trying to make these work. :-)

  • Well, the kicker is, If I use use the VLC app and access the camera over WIFI at rtsp://192.168.1.123:88/videoMain I never see a loss of packets, loss of time, or loss of frames. With VLC, the video over WIFI is smooth and looks near realtime.

    When I observe the cameras via a browser with Foscam's plugin, I don't see jerky motion or loss either, as you have observed, doodah. It looks pretty darn good for 20 FPS. I only see the loss of frames with 3rd Party Software.

    Here is a Screen Recording from Browser with Foscam Plugin

    To answer your question, I am using an ASUS RT-N66U as an access point exclusively for my wireless cameras. There is no wireless contention or signal overlap in the area as I verified with the (Amazing) Wifi-Explorer App. As a test on my MacBook Pro, I get 140Mbit true transfer rate on the LAN so I know the router is capable.

    I also spoke to the developer of the iOS App "LiveCams" and the developer remarked that they have observed the 9805W sending corrupt packets at times. That makes me suspect the WIFI that's built into the is sub-par or they are not opening up their stream to 3rd Party developers.

    I agree about moving on to something more robust. I'm going to make the switch immediately and I'll keep a 9805W alive on the network as a comparison. I still think there is simple solution. The camera seems capable of error free video stream.

    Peter
  • Peter,
    Good info. I think we may have a disconnect. You are using the Asus router as your Wifi router for an exclusive camera wifi network. I set that up as well using an Apple Airport Extreme router. When I am referencing an AP (using Apple Airport Express ), it has been configured not to create a WiFi network but to join the WiFi network setup by my Airport Extreme router. At each camera then I plugged in a separate AP and had it join the Wifi network. The camera was then connected directly to the AP with an ethernet cable. This let me bypass the Foscam wifi. When I did this I had great success. I took that all back apart as I wanted to see what the new firmware did and if anything got better. I think it did get better, but not good enough. I'm trying to get the VLC app to work on mine so I can test with that but am having problems getting that to work. Not sure what the problem is. It comes up and asks for the username and password but then I get an error and I have not been successful in finding VLC log file yet....
  • doodah,

    I did understand your configuration; I should have been more clear on that. In my setup, I was pointing out that the WIFI network itself is not a contributing factor. It's a very clean installation. Your setup would support the notion that Foscam's WIFI implementation is a contributing factor. Perhaps the encryption is an issue. If I may, what type of encryption are you using on the Aiport(s) ? I am using WPA2.

    I did get feedback for another developer who stated that Foscam uses a proprietary protocol for their own use. It was stated that the stream that is made available for "open protocols" and third parties is not the same stream that they use themselves. Maybe Ben knows more about this.

    I had the same password login issue with VLC until I rebooted the camera. Could be I was already logged in using RTSP from SecuritySpy. I just don't remember.

    Peter
  • None of this worked for me. Have a brand new 9805w and have good familiarity with the SS sw over past 8 years and tried everything from onvif to manual to the standard settings. This companies cameras are so well reviewed, I thought I was getting a great solution here, but maybe not so much
  • wccan - please try a firmware update for your camera, available from http://www.foscam.com/down3.ASPX - does this make it work?
  • Hi Ben. Did the update on both cameras. No change. Tried many different configs from manual as one of the other posters tried and onvif, and the foscam one in the as drop down that has similar prior numbers.
  • Try this one... chose Foscam FI8902W, FI9821W. Leave the ports blank and chose H.264 RTSP( audio and video ) as the format. It works on my 9805W. Make sure userid and password are correct. My camera reports system firmware of 1.4.1.8 and application firmware of 2.14.1.10 when I log into it via web browser. I am running version 3.4 of Security Spy. It also works for me using ONVIF. Again I leave the port numbers blank and let it default. Format is RTSP TCP (video and audio) for ONVIF. Input number is set to 1. If I click on the Get Profile List... button I will get an error 32, but when I select ONVIF it defaults to 1 for the input and it seems to work just fine. Username and password of course have to be correct.

    I also put in the ip address for the device... not using a bonjour name resolution or anything.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!