Foscam FI8904W & Firmware 11.35.2.55
  • Because of the security issue with the old firmware, I updated to the latest firmware on my month old Foscam FI8904W.
    Security Spy now refuses to connect - Authentication Error - I have checked and triple checked the password and password, even added a really simple one to the users list and tried that, but I'm still getting the same issue.
    All computers on the network can access the camera directly through its own browser management, Security Spy cannot.
    This camera worked fine before the Firmware update. Any idea what I can do to get it working again?
  • This is not something we have come across before with Foscam cameras (I have seen this a few times with Sony cameras - which is fixed by updating the camera's firmware). If you log on to the camera with a web browser, do you see any settings there for authentication? Sometimes there is a setting to switch between Digest authentication and Plain/simple authentication. If so, try them both. Is there a way to completely turn off authentication in the camera?
  • There's only a users panel where you add u/name & password and type of user (admin/operator/visitor), no choice for auth type. I've tried all types of user too with no change.
    Wish I hadn't updated the firmware now, I only did it because of the security hole.
  • You can try the camera in manual configuration:

    - Open the Video Device Settings window in SecuritySpy
    - Set the device type to Manual
    - Set the format to HTTP
    - Enter the username and password

    Try the following in turn for the Request:

    videostream.cgi

    videostream.cgi?user=xxx&pwd=xxx

    (but actually fill in the correct username and password instead of the xxx marks)

    If the above doesn't work, try again without entering the username or password into the boxes in the Video Device Settings window, instead including them in the Request string only.

    Any luck?
  • \o/
    Adding the videostream.cgi?user=xxx&pwd=xxx worked!
    Brilliant, many thanks :D
  • Great! I'll make sure to build this in to the Foscam JPEG device profile in SecuritySpy.
  • this did not work for me..tried both ways

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!