SFTP Authenticity Error
  • I just noticed that SFTP uploads to my NAS stopped working after years of consistent use. May have been timed when MacOS 10.15.4 was released. The SecuritySpy preference window says the authenticity of the host could not be established. My NAS has a self-signed cert. Have not changed it recently.

    Any thoughts on how to resolve? I tried adding a new server and got the same error.
  • Firstly, please make sure you are using the latest version of SecuritySpy.

    Here's one thing to try:

    - In the Finder, click the Go menu and select "Go To Folder"
    - Enter ~/.ssh
    - Within that folder, you should see a file called "known_hosts"
    - Delete this file by dragging it to the Trash.

    Does that fix it?
  • Hi Ben,

    Thanks for the response. I am running the latest version of SS. No, removing the known_hosts file did not fix the issue. The known_hosts file does not return after deleting it and attempting for SS to connect to my SFTP/SSH server. However it did return when I connected to the server via SSH via terminal and accepted the fingerprint. Any other thoughts?

    I have the ability to do FTPS, but I was having a problem where the video files were appearing on the NAS but were not able to be viewed. Almost like they were being corrupted which is why I went for SFTP which had been working for a long while up until recently.
  • What exactly does the error message say? Are you using the latest version of SecuritySpy?

    FTPS is less reliable, as the connection to send the actual file data is done on a different port, which can sometimes fail, leaving zero-length files. This could be what you were seeing before.
  • Apologies for the delay. Yes, running latest version of SS.

    Log entry is:

    04/04/2020 01:00:40: Error uploading the file "/Users/mike/SecuritySpy/Captured Files/Outside Camera 2 - Back/2020-04-04/04-04-2020 00 C Outside Camera 2 - Back.m4v". 5.2.2,1315,88794 FTP general error. The authenticity of host 'x.x.x.x (x.x.x.x)' can't be established.
    ECDSA key fingerprint is SHA256://6GQ.
    Are you sure you want to continue connecting (yes/no/[fingerprint])?
  • Same error uploading to CameraFTP since upgrading Catalina 10.15.3 to 10.15.4 SecuritySpy 5.2.2
  • Hmm, so files are still being uploaded, and the SS test facility says 'the file was uploaded successfully', but I'm being bombarded with e-mail error reports with the above message.
  • Thanks for the feedback, it looks like there have been some changes in a recent macOS update that have caused SecuritySpy's SFTP function to break. I have made some changes and released a new beta version of SecuritySpy (currently 5.2.3b3) - please test this and let me know if it resolves the problem or not.
  • This has resolved the problem for me, thank you.
  • No new error messages since installing the update, thanks for the prompt response & work Ben!
  • Great to hear that, thanks for reporting back. We'll release this as an official update shortly.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!