Error performing motion capture for camera
  • Got this SS v5 error from an Axis Q1614 that has been working fine with the same setting since SS v3:

    Error performing motion capture for the camera "front", motion capture mode has been disarmed. (Failed to record video frame 5575,818 The key frame interval from the network device is too high, locate and change this setting in the device (may be called I-frame interval / I-frame rate / GOV length / Intra frame period))

    GOP length of this Q1614 camera is 62 (it's default). Is this a Mac cpu performance issue because I added and upgraded some cameras recently?
  • SecuritySpy will tolerate a GOP length of up to 150, so the camera must be ignoring this setting for some reason. It's not a CPU issue; it's a problem with the camera's settings. Please look for a setting called "Zipstream" in your Axis camera and turn it off - this feature can result in a much higher GOP length. Does this resolve the problem?

    In general, we recommend a GOP length of 2x-3x the frame rate. So for example if the frame rate is 10fps then a good GOP length to use is 20-30.
  • Q1614 has no zipstream though my other cameras have it. Those zipstream cameras work beautifully with SS while saving tremendous bandwidth.

    I lowered the Q1614 GOP to 32 and the SS errors did not show again.
  • I am having similar messages from 3 of my Geovision cameras and one Vivotek camera since installing SS V2. The error messages are pasted below: "Front Door" is a Vivotek CC8370-HV, "Garage" is a Geovision and "Kitchen" is Geovision. I have not been able to access client settings in the vivotek. Apparently my browsers - safari and firefox do not support that function. Hardware is a 2019 iMac 27" 5k, 8 GB ram. I am not a techie, any suggestions are sincerely appreciated.

    09/03/2019 14:10:45: Error performing motion capture for the camera "Front Door", motion capture mode has been disarmed. 5.0.1,5575,55340,818 Failed to record video frame. The key frame interval from the network device is too high, locate and change this setting in the device (may be called I-frame interval / I-frame rate / GOV length / Intra frame period).

    09/03/2019 17:40:25: Error communicating with the network device "Kitchen". 5.0.1,10,835 Excessive packet loss from network device, the network may be too slow or defective, or this computer may be overloaded. Check the network and/or reduce this camera's frame rate.

    09/05/2019 20:25:18: Error communicating with the network device "Garage". 5.0.1,8440,800 Failed to obtain video frame from network device. The operation timed out.

    09/07/2019 06:14:24: Error communicating with the network device "Garage". 5.0.1,10,835 Excessive packet loss from network device, the network may be too slow or defective, or this computer may be overloaded. Check the network and/or reduce this camera's frame rate.

  • Hi @ndavies, for your Vivotek CC8370-HV, this setting is called "Intra frame period" and is specified in seconds. Try a setting of 2s for this. The easiest way to get to your camera's settings in a web browser is to go to Preferences -> Cameras -> Device in SecuritySpy and click the "Open in Web Browser" button.

    As for the other errors, these indicate a potential issue with your network or cameras. Some temporary network problems now and then are not unusual, but if you are seeing these messages often, or experiencing significant camera downtime, then this needs to be investigated.

    The first thing is to check your network: the ideal setup is to use a fast (Gigabit) switch from a trusted manufacturer, with all devices connecting into this switch via high-quality Ethernet cables. Is this your setup?

    Another thing to check is that your cameras are using the latest firmware available from the manufacturer.
  • I guess we are stuck on the vivotek, I've never been able to open the "client settings" tab to make adjustments. Their support has been useless so far. For the geovision they were our first cameras, 2+ years old, probably should consider replacing.... The network is totally wired, Cat 6 cables, d-link DES-1018MP 16 ports 10/100 Mbps. Only the cameras are on this switch. I have 12 cameras in total, most are zavio. Never a problem with the zavio cameras.
  • I presume the Mac is also wired into this switch?

    My only comment is that this is a Fast Ethernet (100 Mbps) switch rather than a Gigabit (1000 Mbps) switch, and for 12 cameras I would definitely recommend the Gigabit option. I can't say for sure whether changing the switch would alleviate these errors, because they could also be caused by other factors (e.g. poor camera firmware), but if you do want to make changes to try to improve reliability then this would be the first thing to try.
  • Thanks! Any recommendations on the Gigabit switches?
  • Our go-to manufacturer is Netgear as they have consistently high-quality products. TP-Link also has a very good reputation for switches.
  • For the record, I've been having this issue too from an Amcrest P5M-T1179EW-28MM:

    Error performing motion capture for the camera "Cam1", motion capture mode has been disarmed. (Failed to record video frame 5575,818 The key frame interval from the network device is too high, locate and change this setting in the device (may be called I-frame interval / I-frame rate / GOV length / Intra frame period))

    I changed the settings on the camera to the following and it hasn't occurred again:

    Encode mode H.265
    Smart Codec OFF
    Res 2592*1944
    FPS 15
    VBR
    Quality 4
    Max Bit Rate 6144 Kb/s
    Frame Interval 45 --- appears to be the setting for this issue

    I haven't checked the impact on recording quality yet with keyframes farther apart but will when I get time. The only apparent way I could get control of the Frame Interval is to turn OFF Smart Codec. Otherwise that field was unchangeable/not visible. I assume Smart Codec readjusts the stream parameters based on image/network conditions.

    Amcrest P5M-T1179EW-28MM image quality is pretty good for a $50 5MP IP cam... I got this on sale via an ad from the Amcrest mailing list plus a 10% discount for first time buyers. My previous cams were all dirt cheap Foscams and these are way better (although I think they are rebadged Foscams anyways right?)
  • Yes, the "Smart Codec" feature removes manual control over the key frame rate and instead adjusts it dynamically in order to try to reduce bandwidth. This can result in key frames very far apart, which causes problems for SecuritySpy. Turning this option off resolves the issue, and the difference in bandwidth shouldn't be too much.

    Amcrest cameras are amazingly cheap for what they are, which are basic but well-functioning cameras. They are far superior to Foscam in my opinion. Amcrest shares hardware/firmware with Dahua (not Foscam).

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!