Follow us @bensoftware

SecuritySpy

Multi-camera CCTV software for the Mac


Download Previous Versions of SecuritySpy

If you own a previous version of SecuritySpy, you may like to upgrade version 5, which is a major update with many significant improvements and new features.


Version 4: we are no longer selling version 4, however if you would like to use it, please purchase version 5 using the links on the right; the license code you will receive will also work in version 4 [more info].

We will be providing support for version 4 on systems up to and including macOS 10.14, for the foreseeable future.

Released 23 October 2019.
System requirements: Intel Mac running macOS 10.7 - 10.14.


Version 3 and earlier: these versions are no longer sold or supported.

Released 10 March 2016.
System requirements: Intel only, macOS 10.4 - 10.11.

Released 7 December 2013.
System requirements: Intel or PPC, macOS 10.4 - 10.9.
This is the last version of SecuritySpy that supports PPC Macs.

Released 18 January 2013.
System requirements: Intel or PPC, macOS 10.4 - 10.8.

Released 15 November 2012.
System requirements: Intel or PPC, macOS 10.4 - 10.7.