Setting up a Camera from an RTSP Stream from a Synology Surveillance Station
  • Hi,

    I tried to use the share stream path function from a Synology Surveillance Station to set up a camera in Security Spy. I tried both options (rtsp and rtsp-over-http) but I always get "unrecognised request, check device setup".

    When I use rtsp, the request string is "Sms=12.unicast". I tried "/Sms=12.unicast" and "/Sms=12.unicast/" and "Sms=12.unicast/" as well. Surveillance station has generated the username "syno" and a 32 character password for this stream, which I copied into Security Spy. If I change the request string to "Sms=11.unicast" I get the error "Bad username or password" which seems to prove that everything except the Request String is correct. When I try to view the RTSP stream with VLC it works.

    VLC shows me that the stream is:

    H264 - MPEG-4 AVC (part10) (h264)
    1280x720
    20 fps
    Planar 4:2:0 YUV

    Any ideas?
  • I think you are running into an RTSP compatibility problem that has been fixed in the latest beta version of SecuritySpy (currently 4.2.4b10).

    In this new version, there is a built-in profile for these devices, called "Synology Surveillance Station NVR". So select this as the Profile setting under Preferences -> Cameras -> Device, enter the username "syno" and the 32-character password, and select the input number you want (e.g. 12).

    Does this work for you?
  • Thanks. It works perfectly.
  • Great - thanks for reporting back.
  • One comment about an inconvenience caused by surveillance station for using it with Security Spy: I have set-up 6 cameras from surveillance station in security spy now. Surveillance station has created a separate 32 character password for each of them and if I stop and restart a camera in surveillance station it creates a new password for it, which requires then to copy the new password into security spy for re-activating the camera there as well.
  • That is rather inconvenient. Is there a way to specify a password that doesn't change? What about authenticating with the main administrator login for the device instead of the random 32-character password - does that work?
  • I tried it. It does not work (error: bad username or password)
  • I found an easy fix for this problem in surveillance station:
    IP Camera -> Edit -> Life View Settings -> Advanced -> Stream Sharing Path -> Duration of Validity
    needs to be changed from "1 hour" to "forever"
    Then the 32 character password stays the same
  • That's great! Thanks for posting the solution.
  • Is there a benefit of using surveillance station? It seems more efficient to directly add the cams in SSpy then just write the data to a directory structure on your NAS. Then you can also let SSpy control the rolling deletion of media when the disks get full.

    I use a dedicated network-mounted synology NAS as the destination drive for all of my SSpy recordings and it works well.

    But I never thought of routing the cameras via SurvStn then re-streaming them to SSpy. If there's a real benefit this would be a simple re-config. Any tips or viewpoints on this would be helpful.
  • Dear Ben and community,

    Thank you for such great apps!

    Tried your suggestions from this thread with the latest release of the SS and Synology but I get the "unrecognised request, check device setup" error.
    Tried both the Synology and manual profile but same issue. Has something changed?
    Any suggestions?

    Kind regards,
  • Hi,

    since today, I have the same issue. I updated Surveillance Station. The new SW supports setting the password duration to "forever" directly in the "share stream path" function for each camera. I get the error "unrecognised request, check device setup" when I use the "Synology Surveillance Station NVR" profile and also when I use manual configuration and the "RTSP UDP" Format. The request string is still "/Sms=1.unicast" for the first camera. I tried RTSP UDP" and "RTSP TCP" and have set surveillance station accordingly. It works with VLC to show the stream, but not with security spy. There also seems to be a new "keep alive" setting for RTSP streams in surveillance station which you can select between "None", "Options" and "GET PARAMETER". To work with VLC, I have set this to "None". Any ideas?
  • The error "unrecognised request" means that there is a problem with the request that you are using, which you say is "Sms=1.unicast". However, in your earlier post you said you were using "Sms=11.unicast". Which one is correct, as shown in the device itself?
  • Hi Ben,

    I have several cameras at my Synology, so both #s will work but return different cameras. Of course, each # has a different password. I tried with VLC the "/Sms=1.unicast" and it worked. If I pur a wrong #, then the error is ""bad username or password" and not "unrecognised request"

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!