Issue setting up web account for remote viewing (not recognizing password on iphone app)
  • I just got a new iMac to run SecuritySpy. I did a fresh install instead of copying from my old Mac Mini. So, I've got everything going transferred over except being able to password protect the web server with an account/password. I've can successfully add an admin account with username "admin" and my selected password. I'm able to save the account in SecuritySpy just fine.

    When I go to my phone to setup the server, it discovers the server, but when the SecuritySpy app prompts me to enter my password, it says, "Authentication Failed. Your username or password were incorrect".

    I know my username and password are correct. I've also tried different passwords thinking there might be some sort of restriction on characters, but no luck. Any idea as to what the issue might be?
  • I'm not immediately sure what this could be - there is no known bug relating to this.

    The first thing to check is to make sure you are using the latest versions of SecuritySpy on macOS and iOS.

    Does your password use standard characters? SecuritySpy can cope with most special characters, but not always the more exotic ones, so make sure you are using standard letters, numbers and symbols.

    You can also try logging in from a web browser from another Mac (or even the same Mac running SecuritySpy to check the login - if it works from another Mac then there is some problem on iOS, but if it also doesn't work from another Mac, then perhaps it's a server mis-configuration.

    Finally, if you have multiple SecuritySpy servers, check that you are actually connecting to the right one!
  • Thanks, Ben. I am running the latest software on my Mac (10.13.2) and SecuritySpy (4.2.2).

    Password does use standard characters. I've also tried all letters or all numbers. No luck.

    I've tried viewing from a web browser, but that is not working either (username/password are not recognized).

    I do only have one server. One thing to note is that I am able to connect on my phone or web browser fine to the server with no password protection, it's just when I try and password protect and my iPhone or computer browser won't validate username/password.

  • Ben,
    I am unable to view my cameras using iOS and I can not use a web browser to view them. I can use a Remote Desktop application to see the dedicated server but not the server. I have uninstalled my iOS app and reinstalled and am running SecuritySpy 4.2.3. My macOS is 10.13.2. Have these latest Apple Security updates for the Intel chip security flaws caused this to not work?
  • Hi Ben,
    Same here. I was able to access my cameras over the web without any problems.
    After the last update, I get a message that the server is not responding and timed out?
  • It's difficult to diagnose these issues here - there are multiple different problems being described here, and without further information I cannot provide any specific advice.

    General advice is as follows:

    - Follow our instructions for setting up remote access to SecuritySpy.

    - Make sure you have set up a DDNS address in SecuritySpy's Web settings, and have a green indicator next to it to indicate it is working.

    - Make sure the address and port you are using to connect is correct. SecuritySpy works over port 8000 for HTTP and 8001 for HTTPS by default, so your remote access address would be something like or

    - Check whether you can access SecuritySpy from your local network. When using our iOS app, the server should be automatically detected. If you can access locally but not remotely, then you have narrowed the problem down to the port forwarding or the DDNS name.

    The best way for us to help with problems like this is directly via email support, so please email us and include a screenshot of the Web settings in SecuritySpy, and the "Network" system preferences showing your Mac's network settings.

    @triggs - additionally, could you please set up a temporary account for us in your SecuritySpy web server so that we can test logging on. We just need limited access to one camera to enable us to test this.
  • @Ben - I fiddled with it this past weekend and it seems to be working now. Between updating everything, restarting and setting server back up, the problem went away. I appreciate the help.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!