Hikvision Live View Failed
  • I can't seem to get Live View to work for my Hikvision camera.

    If anyone actually does have it working, please let me know what settings/configuration I need to adjust.

    OS X Sierra 10.12.6
    Safari 11.0
    WebVideoPlugin v3.0.6.12, application/hwp-webvideo-plugin
  • Please be more specific with exactly what you have tried and what problem you are seeing. Have you added the camera to SecuritySpy? To do this, please follow our instructions Connecting to a Camera Over Ethernet - specifically section 1 titled "ONVIF cameras, or cameras that support Bonjour (Zero Configuration Networking)". For the Profile setting, you should be able to use either the ONVIF profile or the Hikvision profile.
  • Did you check your Preferences in Safari under Websites, Plug-ins you might have to enable it. I'm not running High Sierra yet. Still too early for me. I have learned my lesson being an early adopter. Especially with my NVR box. Good Luck.
  • Ben, the Hikvision camera works in SS. What doesn't work is Live View when connecting to the camera in Safari. Connecting to the camera in Safari seems to be the only way to configure the various settings for the Hikvision camera. It woudl be great if Live View worked while configuring the camera.

    meatsuit, yes, I have the WebVideoPlugin enabled.
    Safari > Preferences > Websites > Plug-ins > The box next to WebVideoPlugin is checked.

    Thanks.
  • My guess is that issue is not with SS. Have tried using Quick Time or VLC instead of Webcomponets (WebVideoPluigin). There is a drop down option in the Hikvision Live View window. It works on my Machine. You could also use Hikvision iVMS-4200 for making changes to the camera settings. I use Hikvision iVMS-4200 for making changes. It's a lot easier to make changes on multiple Hikvision cameras because that you don't need to log into every cam individually and you can easily jump between different cameras and setting.

    Cheers
  • If you need this to work, I think the best course of action would be to contact Hikvision support to see if they can suggest a solution. I can't think of anything to try that hasn't been mentioned above. Fortunately, for most users, once they have the camera set up in SecuritySpy they rarely need to access the cameras' web interface directly, so I hope this is the case for you too.
  • meatsuit, it appears that both the Quicktime and VLC plug-ins are somewhat out of date methods. So it appears that I won't be getting Live View to work with Hikvision. It's a shame it doesn't work. But it's not the first time I've (any of us) have come across developes with poor/no Apple Support. Thanks for your suggestions.

    Ben, thanks for you help as well.
  • I have both HikVision and Dahua live view working fine under Safari. My configuration is

    MacOS 10.12.6
    Safari 11.0 with preference tabs...
    Security
    y Warn when visiting fraudulent website
    y Enable JavaScript
    y Block pop-up windows

    Websites
    Java OFF
    WebVideoPlugin ON for webcam IP (version 3.0.5.26)
    NPMedia plugin 1.0 Ask for webcam IP

    After signing into a Hikvision camera, the first page always asks whether to trust the plug WebVideoPlugin. After allowing trust, live view goes active.
  • Just tested with the newer 3.0.6.12 WebVideoPlugin for Mac from Hikvision. It too allows live view under Safari.

    I would check that JavaScript is enabled in Safari security tab

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!