TP-Link NC450 camera and SecuritySpy
  • I've just purchased a TP-Link NC450 HD Pan/Tilt camera to use stand alone with the TP Camera App when the Mac isn't running. It works well, but I haven't been able to use it with SecuritySpy as yet. It finds the camera in preferences auto-discover or I can enter the IP address to view within a browser. However, SecuritySpy doesn't actually connect to it - yet. I'm sure it's just a case of trial and error to get the video up, but I haven't sussed it yet. The drop-down options for TP-Link cameras don't list the NC450, so any advice will be gratefully accepted.
  • Hi,

    Under the Auto-Discovered Devices menu in SecuritySpy, does the camera appear under the ONVIF section, or under the Bonjour section?

    If it's the former, then you should use the ONVIF profile to connect to the camera. If it's the latter, then please let me know and I will supply further information to see if we can get this working for you.
  • The camera appears in the Boujour section and when selecting the 'Open in Web Browser' button to the right of the 'Discovered Devices' button, it opens in the browser at the camera's 'logon' screen. Entering the logon details does then display the video in the camera's admin screen.
  • OK, use that address, and enter the camera's username and password in SecuritySpy.

    Then select the "Manual Configuration" profile, and the "RTSP" Format.

    Enter h264_vga.sdp as the Request.

    Does this work? If so, I'll see if we can add a custom profile that also enables the pan/tilt commands.
  • I'm sure we a are nearly there!

    Here's what I get with the various options with h264_vga.sdp in the Request box:

    - RTSP TCP (video and audio) = Unrecognised Request, check device type
    - RTSP UDP (video and audio) = Unrecognised Request, check device type
    - RTSP-over-HTTP Video and audio) = Unrecognised Request, check device type
    - HTTP (video only) = Unrecognised Request, check device type

    Without the h264_vga.sdp in the Request box, the 2 RTSP options UDP and TCP give the Unrecognised device message. the HTTP options gives Error 801 and RTSP-over-HTTP gives 'communication error'

    I hope this helps in some way.
  • Checking the web and searching for RTSP - there is a link generator that SHOULD work with the NC450. If I put this in Safari, it opens Qicktime Player with a 'live broadcast' but the window is just black.

  • I wonder if the latest firmware update for this camera prevents any access other than by the TP-Link app? By all accounts, using h264_vga.sdp should work for RTSP. It's a shame as the video quality for indoor monitoring is good in daylight and passable at night and the camera isn't too expensive either.
  • There is some talk on Github about getting the NC 250 model working. Might help?
  • This is strange, because h264_vga.sdp should be the correct request. Are you sure there are no extraneous characters or whitespace when you are entering the request?

    Try this:

    - Set the Format to HTTP
    - Enter stream/video/mjpeg as the Request
    - If that doesn't work, try video.mjpg as the Request

    Any luck?
  • No, I'm still getting "Unrecognised request, Check Device Type' in the setup tab window when using:

    - Set the Format to HTTP
    - Enter stream/video/mjpeg as the Request
    - If that doesn't work, try video.mjpg as the Request

    I'm using copy and paste from your posts as well as typing in the request manually, so I think I'm OK there.

    If I choose 'Manual Config' and put nothing in the Request box, this is what I get:

    - HTTP (Video Only) = Error 801 (see log)
    - RTSP TCP (video and audio) = Unrecognised request, Check Device Type
    - RTSP UDP (video and audio) = Unrecognised request, Check Device Type
    - RTSP-over-HTTP (video and audio) = Communication error

    These are the errors from the log - although not necessarily in the order listed above.

    24/05/2017 11:22:38: Error communicating with the network device "Network camera". 4.1.4,70280,404 Failed to obtain video frame from network device. File not found.

    24/05/2017 11:24:53: Error communicating with the network device "Network camera". 4.1.4,70280,404 Failed to obtain video frame from network device. File not found.

    24/05/2017 11:26:45: Error communicating with the network device "Network camera". 4.1.4,80210,404 Failed to obtain video frame from network device. File not found.

    24/05/2017 11:26:47: Error communicating with the network device "Network camera". 4.1.4,80210,404 Failed to obtain video frame from network device. File not found.

    24/05/2017 11:26:57: Error communicating with the network device "Network camera". 4.1.4,89900,8800 Failed to obtain video frame from network device. The server closed the connection.

    24/05/2017 11:26:58: Error communicating with the network device "Network camera". 4.1.4,70219,8801 Failed to obtain video frame from network device.

    24/05/2017 11:27:06: Error communicating with the network device "Network camera". 4.1.4,70291,801 Failed to obtain video frame from network device. Data from network device not as expected.

    24/05/2017 11:27:06: Error communicating with the network device "Network camera". 4.1.4,70291,801 Failed to obtain video frame from network device. Data from network device not as expected.

    24/05/2017 11:29:57: Error communicating with the network device "Network camera". 4.1.4,89900,8800 Failed to obtain video frame from network device. The server closed the connection.

  • Meatsuit, thanks for the pointer, I am making progress now. Using VLC this does display a picture.

  • OK, cooking on gas now!

    I have a picture :)

    Settings are Manual, RSTP TCP (video and audio) and h264_hd.sdp in the request box.

    The only tings I've done differently during this testing is to use the cameras admin panel to change the frame rate from 15 to 30 fps (still no picture) then back to 15 fps (still no picture).

    The breakthrough came when I changed the SecuritySpy frame-rate from Default to 15 fps and the picture appeared immediately.

    Changing the frame rate was one of the hints in the link that Meatsuit gave, so I'm not sure if it was the change using the admin panel or the change in SecuritySpy preferences that did the trick - more testing to follow.

    I can't get the PTZ controls up for the NC450 yet, but I'm working on that.

    EDIT: I don't think that I can access the PTZ controls for a camera setup manually?
  • Great to hear that!

    For the PTZ commands, there doesn't appear to be any technical information published by TP-Link about this, so we'll have to try to find out the commands by other means.

    Are you able to control the camera's pan/tilt using a web browser (e.g. Safari) on your Mac, by connecting to the camera's IP address to view its web interface?
  • Ben, yes, connecting to the camera admin interface using Safari I can pan/tilt using the controls on the page.

    I can view the admin page source code, but I don't really know what I'm looking for.
  • Not sure if this helps, mouse down to pan 'e' and stop when mouse button is released. = "start"; = "e";


    INTERVAL_TIMER = setInterval(function(){

    }).mouseup(function(){ = "stop";


  • Here's how you can determine what these PTZ commands are:

    - Download the trial version of the HTTP Scoop software.

    - If the camera’s HTTP interface runs on any port other than 80, go to the Preferences, and add the actual HTTP port, as follows (e.g. if it runs on 88):


    - Select the network interface that your Mac uses to connect to your network, and then press the Scoop button:


    - Then, perform some pan/tilt movements via the camera’s web interface. HTTP Scoop should then display each of these requests in its main window:


    - Double-click on any of these to show the detail of the request. Under the Setup tab, it is the "Request URL" that is the important information


    - Please copy and paste here the request URLs that correspond to the camera’s movements.
  • It shows the same regardless of the direction chosen:
  • Request/Response Post data shows:

    Up = operation=start&direction=n&token=5t4lhnpb98c49s9

    Down = operation=start&direction=s&token=5t4lhnpb98c49s9

    Left = operation=start&direction=w&token=5t4lhnpb98c49s9

    Right = operation=start&direction=e&token=5t4lhnpb98c49s9

    Which seems to indicate N,S,W,E

    And then a stop command when you release the mouse button (in this case for S/down):

  • These are the right commands, however the presence of a token parameter (which is highly unusual and could be a method of authentication) indicates that it's not as simple as it should be. I will have to contact TP-Link to ask them for technical information about this. I'll let you know what they say.
  • Ben, thanks for all your help with this. I'm quite impressed with the camera as an indoor camera and the price is reasonable. Nighttime performance is passable rather than being great, but it's still useable. My other cameras are a mixture of wired and wireless old Edimax VGA's and a VGA Foscam 'clone'. Maplin sell the NC450 so it's easily available. I can use the TP-Link Camera Android/iOS app to direct the camera independent of SecuritySpy, so the PTZ control is a 'nice to have' rather than essential.
  • Not sure if this helps any? This is what shows in the Header > Cookie field of HTTP Scoop when using one of the admin page pan buttons. Passwords commented out, but I've left a bit of the token. I suppose that this token could be unique to this camera/account?

    CameraType=NC450(UN)%202.0; StreamAccount=admin; StreamPassword=**********; Token=nt5mo****4egq2b; UserName=admin; isAdmin=1; sess=************; tplanguage=EN
  • Added a second TP-Link NC450 to my SecuritySpy system as my 2 old Edimax cameras have started to become unreliable. Apart from a bit of a faff connecting the camera to my wifi using the TP-Link software (same with the first camera), setting this one up for SecuritySpy was simple. I set the camera to 15fps and then selected the same in SecuritySpy preferences and the video appeared immediately, so maybe the post I was directed to regarding the camera feed and the frame rate was relevant? The cameras are generally in a fixed position, but I can use the TP-Link app to move the view if needed.
  • I have heard back from TP-Link. They state that the camera supports ONVIF, which will give us video and PTZ control. In theory this is true as long as the camera supports it, however this isn't mentioned on the spec sheet on their web site, and I already suggested this above, and your response indicated that ONVIF isn't available.

    Could you please check through the camera's settings pages to see if there is any mention of ONVIF at all, or any option to turn it on?
  • OK, I'll take a look
  • No, can't find any ONVIF setting. The Maplin sale spec says ONVIF N/A and a Google search doesn't bring anything up for ONVIF for this camera.

    The only option in the camera setup is to set Bonjour off/on

    With the camera set to ONVIF in SS and the ports left blank, the 'Choose Stream' window doesn't show anything if that's relevant at all. I've tried all 3 formats but only get an 'Unrecognised request - check device' when attempting to connect.
  • TP-Link NC450 data sheet does mention:


    Both my NC450's are version 2 and have the latest firmware installed.
  • True! It does say onvif. Once this get worked out... Im going to buy one!
  • I Joined the TP-Link Support Forums.
    Ask: How can find the onvif profile shown in there NC450(UN) V2 Datasheet data sheet?
    We will see...
    Waiting for Question to post...
  • I've provided this feedback to TP-Link and they said they'll pass it to a senior engineer and get back to me. I'll post back here when I've heard back from them.
  • Thanks for following this up Ben. It's good to see TP-Link responding to your requests, not always the case with some companies.
  • TP-Link has replied that the latest 170322 firmware adds ONVIF support - it's available here:

    You mentioned above that you have the latest firmware installed, but please double-check that you have this exact version, and if not, please update your cameras.

    Any luck?
  • Yes, I have this firmware on both my cameras - 1.2.4.Build 170322 Rel.85B2CB - and I updated to this firmware the first time I fired the cameras up.

    So, no update to what I reported above. No mention of ONVIF in the camera admin page when accessing the camera directly by IP address. I wonder if there is a utility that can 'test' for the presence of an ONVIF camera? Using both the admin panel and the TP-Link iCloud interface, and their Android and iOS apps, I can see the video and control the movement of the cameras, but I just can't get SecuritySpy to recognise them as ONVIF cameras.

    It could still be finger trouble on my part, but I've tried all possible options in SecuritySpy options. As I have Bonjour activated rather than disabled, might that somehow disable ONVIF. I did try disabling it but it didn't seem to make any difference. I'll try again.
  • Bonjour disabled, ONVIF selected with RTSP TCP (video and audio) set.

    02/06/2017 14:09:43: Error communicating with the network device "NC450 Garden Cam". 4.1.4,8440,404 Failed to obtain video frame from network device. File not found.
  • Searching the TP-Link support forum for ONVIF brings up lots of questions from users, but no answers from the company.
  • OK apparently the camera uses port 3702 for its ONVIF communication. So please try the ONVIF profile again, and specify 3702 as the ONVIF port. If this works, it should get pan/tilt working as well as video.
  • Ben, many thanks. I can't test this at the moment, but I'll get back to you with the results.
  • Ben, ONVIF port 3702 works with the NC450 like a charm!

    IP address added manually, ONVIF port set to 3702 and RTSP TCP (video and audio) added as the format. Selecting the individual camera window brings up the PTZ button and allows directional control.

    However, one of the cameras does seem a bit flakey. It ran OK with ONVIF and initially responded to the SS PTZ commands, then I tried to set presets which didn't seem to work. PTZ commands then stopped working and although I've been through the whole factory reset and setting up again in SS, whilst the video is fine in manual mode, it just won't connect in ONVIF mode. As the other camera is working OK, it's got to be a camera issue. I'll play with this some more when I have the time. Reflash the camera firmware maybe?

    I had to go through the 'change framerate' process in the camera admin to get the video to show at all in SS too. Hmmm, cheap camera, you get what you pay for maybe!
  • Glad to hear it's working!

    Try the latest beta version of SecuritySpy (currently 4.1.5b20) as this has some fixes for camera PTZ problems.

    If that doesn't work, then try a factory reset of that problem camera again.
  • Thanks, will look at this
  • Ben, Beta running OK and found a way to get my 'reluctant' second NC450 to be recognised as ONVIF. It's fine when wired and fine when connected to the wifi when you unplug the ethernet cable - however, when I powered it down to move to the operational location it just wouldn't connect via ONVIF.

    The solution was to put the camera in the location, connect it by ethernet, power it up to get the ONVIF video and then unplug the ethernet cable. Works fine, go figure. I don't suppose the connection would survive a power cycle though.

    The PTZ works well, but I haven't tried saving presets as yet.
  • Good to hear you managed to get it working, but the WiFi connection does sounds like it's unusually fragile. Is the WiFi reception OK in the new location? You might want to ask TP-Link support if this problem is ongoing - in my experience they have been very responsive and helpful.
  • It's odd, but the actual wifi connection is as solid as a rock on both cameras, each one being no more than 15 feet from a hotspot. It's just that one of the cameras refuses to connect via ONVIF using wifi UNLESS it's connected first by ethernet cable and then the ethernet cable is disconnected to force it to wifi. Connecting in manual mode as per your instructions works for both cameras via wifi, it's just the second one than needs 'starting' in ONVIF mode before disconnecting the ethernet cable. It's such a vague issue that I'm not sure TP-Link would be able to debug it.

    I'll keep an eye on it and do some more testing.

    Nice to know that TP-Link are responsive. Reading the various forums suggests otherwise, but of course it's only the 'dissatisfied' customers that make all the noise :)

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!