FI9821W V2 video "stutters" like Max Headroom
  • I've been using 4 Foscam IP cameras with SS for many months. Up until recently, it just worked 24/7 doing its thing without complaining. I had been running 4.0.x then upgraded to 4.1.2 when all of the sudden the video from one of my cameras will begin stuttering like Max Headroom. It will flicker back and forth between a previous frame anywhere from a fraction of a second to a few minutes prior and will sometimes stop on its own and will temporarily recover if I restart SS.

    Same computer. Same cameras. Same settings. I tried using a newer, beta version 4.1.3, which didn't help. The video that appears in the camera's webpage looks normal.

    Here's an example:

  • Hi, this does appear to be a bug in 4.1.2 that is affecting a minority of users. Have you tried the latest 4.1.3b5 beta version of SecuritySpy? We've had reports from other users that this fixes it. Perhaps you are using a previous beta version?
  • Unfortunately, it did not. I just downloaded and ran 4.1.3b6. Within seconds of opening it, the stuttering started and continues at this moment - actually, it seems worse. The other Foscam cameras are operating normally.

    Doing anything to "disturb" SS such as viewing through the remote app or resizing the window seems to temporarily resolve the issue. The captured footage appears normal follow a brief review. So, during my brief testing it looks like only the way the video is being displayed in real time in SS seems to be the issue - and, again, it's only on one camera.
  • Thanks for reporting back, I've just posted a new beta (b7) with some further changes. Do you see the same problem with this one?

    Is there anything significantly different about the setup of this one camera, compared to your other ones that don't display this issue? For example, is recompression turned on for this camera but not the others (under Preferences -> Cameras -> Device)?
  • Same Problem with my D-Link cams. Just after downloading latest Version: 4.1.2 - One by one cams start this stuttering, I changed from 4:3 to 16:9 and that made stuttering stop for now, but I don't know for how long.
  • I just downloaded the beta this actual beta version, and immediately the cams started to stutter again.
    I have not turned on recompression for any cams. I have 3 different models, the stuttering is only with the d-link cam models. Not with the older ones (elro and fitivision models).
    How can I go back to the previous software a.i. downgrade?
    Thanks for help
  • edit - I found the former version 4.0.10 in my downlaod folder. This one works fine.
  • I have the same issue. Ben, I emailed support earlier. Going back to 4.1.1 solved the problem for me as well. I've got all Axis cameras, however.
  • @Ben, it's even worse with b7. Now, all four cameras are freezing/stuttering (three different models of Foscams). Three are Foscam H.264 / RTSP. One is ONVIF / RTSP. I've never changed any settings since my initial setup last year when I purchased the software and configured it for my cameras.

    I've gone back to 4.0.10 I found in my downloads folder and it seems to be working perfectly - at least as of this reply.

    EDIT: I found a copy of 4.1.1 and installed that and will monitor it for problems. Again, it's working as of this edited reply.
  • @zroger73 I noticed that setting my cameras to JPEG instead of H.264 resolved the issue temporarily (until I switched back). Did you have a chance to test that out as well?
  • Thanks for your feedback everyone. I've just posted a new beta version of SecuritySpy (4.1.3b8) that I'm hoping will fix this issue. Please let me know if this is the case or not.

    If anyone wants to go back to the previous release, it's here: download SecuritySpy 4.1.1.
  • @Ben, 4.1.3b8 has been running about an hour now with no stuttering.

    I did notice that one of the cameras (the ONE of four that stuttered the least) froze when running 4.1.1.

    So, in hindsight, at least from my perspective, it seems things began "breaking" in either 4.1.0 or 4.1.1. I believe version 4.0.10 was rock solid for me.

    Thanks as usual for your quick attention - this is one of the things that makes your software worth the price!
  • Thanks Ben and to all for feedbacks.
    The really steadiest working version is still 4.0.10 one. Ok, the live browser function is not the best, but unfortunately this issue hasn't been solved in either versions as far as I see?
  • I was about to write about this bug, but sounds like it is being worked on. Will have to test with new beta. I agree, the problem arose somewhere around 4.1.0. That's when I started seeing cameras stuttering and even outright crashes of SS upon relaunch of the app. Thanks for working on the fix.
  • Hi @heimchen and @guykuo - multiple users have now reported that the bug is fixed in 4.1.3b8 so if you have time, please do give this a go and report back.
  • Hi all, we have just released a new version of SecuritySpy (4.1.3) that should definitively fix this problem. Use the "Check for Update" feature in the File menu in SecuritySpy to update.
  • 4.1.3 installed couple of hours ago and its working fine. Thx @Ben for the update
  • Thanks for reporting back!
This discussion has been closed.
All Discussions

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!