Freezes - EL Capitan or Security Spy
  • I am running 10.11.5 of El Capitan.

    I have a Mac Mini Late 2012 with a SSD drive and 16gb of RAM. I have a clean install of El Capitan which was performed using a bootable OSX Apple Recovery disk which installed EL Capital directly rather than having to upgrade.

    The only applications running on the machine are Security Spy and Plex Server.

    After a lot of experimentation, full reinstalls and trial and error I have found the following.

    If I set Security Spy to perform all motion detection and recording (which increases network traffic) - workload on Security Spy the OSX machine often runs for 1-2 days before it just freezes. By free I mean the network seems to stop. If I go to the console I can press a key to trigger the display to appear (power saving monitor off). The login screen is displayed but if you try and logon all you get is the beach ball and you have to do a full power off on to carry on.

    If I set Security Spy to only view the cameras so that it's effectivy idling until someone uses a mobile app or web browser to look at a camera then the system remains stable for about a week before it happens again. When using this mode I switch the cameras to perform independent motion recording to a ftp server.

    I have done a boot into hardware diagnostics and it did not find any fault. I have also looked at the system log but it does not show anything. Today for example the logs just stop at 2am. I did a reboot and it's all working now.

    So - maybe the freeze is more frequent the more network i/o is occuring ?

    I'm not convinced that this is a SS4 as it started before I upgraded. I have read about freezing issues with El Capitan 10.11.4 & 5 but I don't know if that's causing the issue or not as there is literally nothing to go on.

    Today I signed up for the OSX beta and I've installed the latest 10.11.6 - so I will post an update as and when I have any news.

    Does anyone else experience freezes like this ? I hope it's not a hardware issue as it's all out of warranty now and it would probably be cheaper to replace it that start a trial and error swap out of components.

    Thanks in advance


  • I have no crash with SS4 at this time.
    Mac-Mini mid-2011, 240gb SSD and 16 gb RAM. Mac OS 10.11.5.

    Only two apps are always on: SS4 and PS3 Media Server (like Plex, but more simple :) )

    There is 6 cameras:
    - 2 cams continous record (1280x720)
    - 2 cams with motion detection (armed all the time)
    - 2 cams with motion detection (armed when I'm not at home)
    Motion detection send an email when a motion is detected.
    Video streams are recorded on a external USB disk (2To), not on the internal SSD disk.

    Cams and mac-mini are connected on a gigabit switch (cams are connected to 100mbps but the mac is connected to 1gbps).
  • Thats good to know - although it's obviously a bit depressing as it implies my hardware might be the issue. I will leave the current beta running and if that does not help then it looks like I'm going to have to spend some cash.
  • I've reset the SMC/PRAM removed a USB camera and installed the latest Beta - I've also left the console log screen open in case it shows anything helpful. The clock is running - fingers crossed.
  • So far still running. I had 8 cameras but 2 of them were local so I've removed the usb devices. I've also left the console log open on screen in case I can catch something on screen if it locks again.

    I see the latest Mac Mini is only dual core, not sure how a faster clock compensates for less cores.
  • I see a lot of these errors in the OS X log. Any idea what it means :-

    04/07/2016 16:42:39.528 SecuritySpy[257]: AVF error: Perf capability check failed: 0xe00002be
  • Hi Dave,

    These problems are the most difficult to track down, I don't envy you! There's nothing particularly about SecuritySpy that could trigger this, except that it uses system resources (RAM, disk, network etc.) so if there is a fault with your Mac it is likely to be shown more when something is running doing something.

    If you installed the RAM recently, you could be looking at a bad chip. You could try taking the modules out a testing them one at a time. Is the SSD new too?

    There is nothing in particular about OS X 10.11 that I know of that would make it susceptible to this, though you could try a different system version as a test (e.g. OS X 10.10).

    We have also seen the "Perf capability check failed" message, and it has proven impossible to work out what it actually means! However as far as we can tell, it's a harmless message and can be safely ignored.
  • I have seen that a few times with different apps in El Capitan.
    I thought it was a little warning like it checks for hardware video decoding and failed, but maybe not as your Mac I think should be able to do HW video decoding so must be something else...
  • Well 2 days and still ok - which is encouraging - however I will probably hex it by saying this. The 2 changes I've made are updating to El Capitan Beta 10.11.6 and removing 2 local cameras, one a USB and one a built in camera in the apple monitor. I run an application to monitor the temperature of the computer and it tells me that it's working hardest at night - I assume its related to the camera's returning a more pixelated image. Only 2 have infrared.
  • Yuck! Hardware freezes are tough. Reminds me of the MacBooks that would thermal fail and freeze or shutdown.

    A couple instances of terminal running yes command to thermal stress the CPU would verify the diagnosis in a few minutes. If you think it is a CPU thermal failure, open some terminal windows and run

    yes > /dev/null

    You'll see CPU usage skyrocket by about 1 entire core for each instance of yes. This lets you quickly see if you have a high temperature intermittent.

    Be sure to close those terminal windows to kill the yes processes when done.
  • Last week I was doing a lot of CPU intensive work on the Mac Mini and it got quite hot. I let it running overnight and the following morning it had crashed displayed that special symbol on screen witha question mark. A look at the logs found this, a small extract is below :-

    Anonymous UUID: 228ABA51-63DD-626B-AF64-685751F23768

    Fri Aug 5 07:19:59 2016

    *** Panic Report ***
    panic(cpu 4 caller 0xffffff8022bce6fa): Kernel trap at 0xffffff7fa5305586, type 14=page fault, registers:
    CR0: 0x000000008001003b, CR2: 0xffffff81e60b3004, CR3: 0x0000000025fe0000, CR4: 0x00000000001626e0
    RAX: 0x0000000049453041, RBX: 0xffffff8048834600, RCX: 0x0000000000040004, RDX: 0x0000000000000003
    RSP: 0xffffff820c6a3d28, RBP: 0xffffff820c6a3d30, RSI: 0x0000000000040004, RDI: 0xffffff80439f0000
    R8: 0xffffff80491c8800, R9: 0xffffff804396cc00, R10: 0x00000000fffffffc, R11: 0xffffff81e6073000
    R12: 0xffffff7fa5327a98, R13: 0xffffff80491c8800, R14: 0xffffff8043891300, R15: 0x0000000010001000
    RFL: 0x0000000000010202, RIP: 0xffffff7fa5305586, CS: 0x0000000000000008, SS: 0x0000000000000000
    Fault CR2: 0xffffff81e60b3004, Error code: 0x0000000000000002, Fault CPU: 0x4, PL: 0

    Today I have replaced all the ram chips (2 x 8gb). Hopefully this will help. I know the units do run hot but I'm not sure if the thermal changes might cause the RAM chips to fail or maybe the socket / seating to expand and break the connection.

    Fingers crossed.
  • Hi Dave,

    Thanks for sharing your experiences here. I'm also running a Mac Mini Server with 16GB RAM. I'm running 6 cameras and am suffering a very similar situation to you. I'm starting to feel that the issue points towards El Capitan and SecuritySpy. I downgraded to Mavericks a month or so ago and everything seemed to work reliably. About 10 days ago, I stupidly thought I'd upgrade to El Capitan (I usually think it's best to run the latest OS whenever possible) but now I'm suffering from Mac freezes, the Mac crawling to a snails pace where mouse clicks take 10 secs + before menus open, apps quit etc. It's painful. I think it's now corrupted the Operating System as it now doesn't boot without it being painfully painfully slow. I also noted that SecuritySpy kept quitting and restarting regularly when it was running. All very very odd.

    I've removed RAM chips, swapped them and it's made no difference. I still believe the hardware is fine (I used Apple's hardware test.)

    Whilst this is a painful experience, I'm glad I'm not alone. I believe it's a SecuritySpy and El Capitan issue, but quite what I don't know.

    There is plenty of discussion on the Apple forums about El Capitan issues...

    I'm about to downgrade the OS again. All very tiresome. Please let me know if you discover anything useful and I'll do similar.

  • I replaced my ram and I have also put a small usb fan next to the mac mini to keep it cool. Having said that yesterday when I checked the console it had reported that it had rebooted itself. So I still don't know what the issue is.
  • I've completely reinstalled the Mac Mini Server Late 2012 and running Mavericks. It has been running 24hours now with no crashes or sluggish performance. I've even written a post it note to remind me to avoid upgrading to El Capitan. Something is definitely awry with El Capitan and SecuritySpy or maybe just El Capitan. That said, my own home Mac Mini is running just fine. I think it's the same vintage Late 2012. The only difference is that this one is a 2.3GHz i7 machine compared to the 2.7GHz i7 machine which has problems. Both have 16GB memory.

    All very strange.

    Do you have an update Dave?
  • consider running a ram tester like the free (donationware) memtest86+ (burn ISO to CD - assuming you have something that can burn CDs, and a USB optical drive to connect to the Mac mini)
    there are several pay-for ram testers with GUI, or the pretty cheap that is command-line and can be run from single user mode (if you put it in the /bin/ directory) to test all but the first 200 MB or so of ram. Personally (likely from having been a tech for 20+ years) I run memtest on any ram I install in computers, or on other peoples computers that are having weird issues. It may only be one in every 50 to 100 that is ram at fault, but if the ram isn't verified as being good it could be causing all kinds of weird issues. (I also usually run memtest overnight or a full day when possible doing several many tests

    I do run SMC Fan Control to keep my fans running a bit higher than normal to keep the temp stable on my Mac mini 2012 (2.3 Ghz i7) - with fully default (no SMC fan control) the temperature fluctuates quite a bit, and the fans would go from idle speed to quite fast every so often (sometimes every few minutes, sometimes might be 15-20 minutes for the cycle) - in SMC Fan Control I set a minimum fan speed of 3300 rpm and most of the time it stays steady at that speed - it can still run the fans faster if needed.

    With 10.10 I found I had to reboot every couple of weeks or eventually the system would crash because of the video drivers - with 10.11 (El Capitan) the integrated intel video drivers are more stable I've frequently gone beyond a month and am usually restarting for other things like software updates, maybe only once or twice have seen video artifact issues. I did wait to go to El Capitan until 10.11.2 or .3 there are typically issues with releases for .0 and .1 (my Mac mini runs security spy, OS X Server for Caching server & web server, Plex - including frequent transcoding of video, as well as more typical apps)

    Hopefully something here can help you guys find the issue.
  • I have done the following, and although I have had one mystery machine restart and a couple of instances of the application restarting I think there has been an improvement.

    Replaced RAM
    Used external USB Fan (which reduced the ambient internal temp by 10'c)

    I have also updated to the latest EL Capitan.

  • My server rebooted again, this is a partial dump,

    Anonymous UUID: 228ABA51-63DD-626B-AF64-685751F23768

    Fri Aug 19 22:22:19 2016

    *** Panic Report ***
    panic(cpu 0 caller 0xffffff80081ce6fa): Kernel trap at 0xffffff80082f6938, type 13=general protection, registers:
    CR0: 0x000000008001003b, CR2: 0x000000010f1e5000, CR3: 0x0000000009ce6001, CR4: 0x00000000001626e0
    RAX: 0xffffff80418e8c50, RBX: 0xffffff80272fda08, RCX: 0x7fffff80418e8b40, RDX: 0xffffff80272fda58
    RSP: 0xffffff81f174bd30, RBP: 0xffffff81f174bdd0, RSI: 0x000000000000e000, RDI: 0xffffff80272fda20
    R8: 0x0000000000000001, R9: 0x0000000000000000, R10: 0x0000000000002000, R11: 0x000000000000000a
    R12: 0xffffff80418e8c30, R13: 0x0000000000000000, R14: 0xffffff80272fda20, R15: 0xffffff80272fda58
    RFL: 0x0000000000010202, RIP: 0xffffff80082f6938, CS: 0x0000000000000008, SS: 0x0000000000000010
    Fault CR2: 0x000000010f1e5000, Error code: 0x0000000000000000, Fault CPU: 0x0, PL: 0

    mp = 0xffffff80272fda08, phys = 0x9423a08, prev (0x7: 0x7f13000-0x8000000)
    vp = 0xffffff80418e8c30, phys = 0x13c12bc30, prev (0xb: 0xffe70000-0xffea0000)
    Backtrace (CPU 0), Frame : Return Address
    0xffffff81c6fd7c50 : 0xffffff80080dab52
    0xffffff81c6fd7cd0 : 0xffffff80081ce6fa
    0xffffff81c6fd7eb0 : 0xffffff80081ec563
    0xffffff81c6fd7ed0 : 0xffffff80082f6938
    0xffffff81f174bdd0 : 0xffffff8008527f73
    0xffffff81f174bec0 : 0xffffff800830feed
    0xffffff81f174bee0 : 0xffffff80082fa0b4
    0xffffff81f174bf50 : 0xffffff8008304ea7
    0xffffff81f174bf60 : 0xffffff8008628701
    0xffffff81f174bfb0 : 0xffffff80081ecd66

    BSD process name corresponding to current thread: launchd
  • My server is still running, uptime of 5 days. Doesn't appear to have had a singe reboot. Mac OS X still reminds me to upgrade to El Capitan. (no chance!)

    Dave, have you tried downgrading to Mavericks?

  • $ uptime
    7:50 up 32 days, 14:22, 3 users, load averages: 2.47 2.69 2.58
    Mac OS X 10.11.6 (15G31), Security Spy 4.0.4 then 4.0.5 the last day or so.

    For DaveGarret - it shows that LaunchD was the process running on that CPU core when it panic'd.
  • I don't really know what Launchd is, there are only 2 apps running on the Mac Mini at any time, SecuritySpy and Plex. It could be a hardware issue, El Capitan or either of the apps. I have changed the RAM with no obvious improvement. This afternoon the server became unresponsive (remotely), when I looked at the console I got a black screen with a mouse pointer, but nothing else. I forced a power off - on and the machine came back ok. OSX did not complain that there had been a previous problem or power outage so rather unhelpful. I probably will try reverting to a previous version of OSX eventually.

    In case there is a pattern I have a upgraded SSD drive fitted and 16gb of ram.

  • LaunchD is a system level process that basically controls what low level system services startup and keeps them running.

    completely unrelated to SecuritySpy
  • Today I could not connect to the camera's remotely. When I got to the physical console all I could see was the mouse pointer and a black screen. The mouse moved around and after presssing a few random keys the mouse pointer changed to a rainbow spinning wait symbol. The server was down as I could not connect to it remotely. Again a full power off on fixed the problem. Nothing in the console log between the stop and start. Looks like I will be trying your suggestion of Mavericks. Very odd I must say.
  • Froze again last night. Initially noticed that I could not connect with iPhone app. Went to console and pressed a key which woke up the screen. All I could see was a black display and a beach ball. Nothing to do apart from hard power off and on again. When it came back OSX did not report the fact that it had recovered from a reboot or unexpected power outage. Nothing in logs. The only thing which might have been relevant was there was a pending update for iTunes - which I don't use on that machine anyway. In fact the only 2 apps which run on this machine are SecuritySpy and Plex. Plex had been used the previous day for a few hours. Also I noticed that a spider was causing continuos motion detection on one of the outside camera's which would have been keeping SS busy. Apart from that no idea what the cause could be. Still running EL Cap, might have time for a downgrade to Mavericks eventually.
  • it isn't a generic El Capitan issue, I work with many Mac mini's where I work, as well as my own at home, and my mothers - all 2012 year models. If there was an general OS problem it would be seen. What is more likely is an undiagnosed hardware issue, or a specific corruption in your install. (And the Mini's do a variety of tasks, mostly fairly intensive or heavy network - with my home one doing what yours does and more - Security Spy with 6 or 7 cameras 2 doing continuous recording, Plex, Server, music & photo sharing, general web browsing, etc..)

    Check for firmware update for your SSD (backup data/clone drive before doing a firmware update on SSD if there is one, just to be safe)

    As a tech if something isn't stable, I start with ram test (which also tests CPU to some extent) if that passes at least an overnight run of repeated tests, then I test the hard drive next (no free software to do this unfortunately), if that passes as well, I run the system off of an external drive attempting to reproduce the issue - if it doesn't, it could be a software issue with the particular install of the OS, try a backup format & re-install of the OS - if it does reproduce then its harder, could be something wrong with the system that isn't showing up in the ram/hard drive tests - flakey cable/drive/power supply.

    (My mothers 2012 Mac mini did have an issue last year with some freezes, and eventually more and more frequent sudden power offs usually when she wasn't using it, eventually it wouldn't turn on - applecare warranty replacement of power supply and it was back to normal operation, would have gotten it fixed sooner, but she didn't tell me about most of the problems until it wouldn't turn on any more)
  • Thanks for your feedback. I am running the latest Crucial for my firmware and the RAM was changed about a month ago to eliminate that. Give the age and number of non Apple hardware updates I don't think getting the apple store to look at the power supply is an option now. My next change will be a revert to Mavericks. I'm a software tech so I will follow that option next. It don't freeze "solid" it seems to go into a partial sulk with network and user interface failing to respond. The mouse pointer is there but stuck in a beach ball with kinda hints to some process doing something.
  • My server seems to have settled down now and the only thing which I've changed is that I'm not running the application which monitors the temperature of the various hardware compontents any more. Of course now I've said that I will have tempted fate and it will no doubt go wrong again. However if anyone else is having this freeze problem and they are running the same app it might be try stopping it for a few days to see if things improve.
  • I have been chasing the same problem. Today, while accessing SecuritySpy remotely, my MacPro became unresponsive. As before, the only way to fix it is to reboot the computer. I use SecuritySpy with indigo to control my house, and it locks up indigo as well. House network remains up and camera's are accessible via another program that does not need my MacPro. I'll need to install a IP Power Switch to enable a remote solution until I can confirm its a problem with SecuritySpy.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!