Setup questions after SS upgrade
  • Hi Ben,

    After upgrading from an iMac G5 and the older PPC version of security spy to a new Mac Mini and the latest version, I have 2 problems:

    1. I have some Foscam FI8904 MJPEG cameras that really clog up the network. I want to use the slower frame rate option detailed in this thread:
    http://www.bensoftware.com/forum/discussion/656/significantly-lower-frame-rate-possible/p1
    But when I select the "Manual" camera option, the "request" field does not exist! Any ideas?

    2. I can't view captured movies. I have motion triggering a new file for each event. However, when I view them via the remote web server, I just get a quicktime "Q" with a question mark in it. I've tried all of the encoding formats but the result is the same. The file appears to be on disk, but it is not playing. (I haven't tried to play it locally as I only access SS remotely).

    Thank you!
  • Hi Jeff,

    Firstly, please make sure you are using the latest version of SecuritySpy (currently 3.4.4). I have just tested the Manual option and the Request field is definitely there:

    image

    As for the captured movies, have you tried different web browsers? You should have no problem using Safari or FireFox (the latest Chrome has some issues). Also, in the new 3.4.4. version of SecuritySpy you have the option of downloading the movie files to disk rather than viewing them in the browser. If you use this option can you view the files OK?
  • Thanks for the reply.

    We are on the current version of SS (just downloaded, but I can't see the version number because I'm administering this remotely). Could it also be that the "request" field is not available when changing camera settings remotely?

    Browser: I have tried Firefox and Safari on a Mac, and Safari on iPhone. These all worked previously, when SS was hosted on the G5 iMac. Could it be that the new host Mac doesn't have Quicktime installed?
  • Hi Jeff,

    That explains it - I didn't realise you were adjusting the settings via the web interface rather than in the software's user interface directly. Sorry but this appears to be an omission in the set of settings available via the web interface. We will add this in a future update, however for now you'll have to set this directly from the Video Device Settings window SecuritySpy's user interface.

    As for QuickTime: all Macs come with QuickTime installed by default. One thing you could try though is to download and install QuickTime Player 7, which isn't installed by default, and may resolve the problem.
  • Jeff, I recommend always having a copy of VLC handy, which will play just about any format you throw at it.
  • 1. "Request" field issue: I was on-site today and the request field did indeed appear when I switched camera type to "manual". Thank you! The Foscams are now limited to 2fps and are no longer maxing out the local network.

    2. Safari Quicktime issue: I've tried every fix Google had for the "Quicktime question mark" issue, to no avail. I can fix the problem on the Mac by using Firefox, where the movies play fine. What's interesting is that they worked fine in Safari until we upgraded the server mac from a G5 iMac to an Intel Mac Mini. (It's an older model Mac Mini, running snow leopard and SS 3.4.3).

    However, Safari for IOS is still not playing the captured movies. There is no Quicktime logo or question mark, the movies just say "loading" in the lower left corner but never load or play. Is there a file format for the movies I should be using for IOS remote viewing?

    Thanks in advance, Jeff

    P.S. Thanks opticalserenity, I do have VLC but I'm trying to make this as easy for other users who just want it to play when they click!
  • Hi Jeff,

    Great to hear you managed to set up the Foscams as you wanted.

    As for the movies - are you accessing SecuritySpy's web server over HTTP or secure HTTPS? If the latter, you will need to install a proper SSL certificate for SecuritySpy, otherwise many browser such as Safari will refuse to play the movies.

    If you're connecting over regular HTTP, let me know and I'll investigate further. In this case, if you can allow us temporary access to your SecuritySpy server this would be the best way to troubleshoot.
  • Ah, you are correct! My Safari bookmark is for http://etc. but Safari changes it to https right away when I access the page.

    Strangely, Firefox does the same thing but the movies play fine in Firefox.
  • Hi Jeff,

    Good to hear you worked it out. If you try to connect over HTTP to SecuritySpy's HTTPS port, SecuritySpy send a redirect to the HTTPS address. And yes it's just Safari that refuses to play the movie files over HTTPS without an official certificate; FireFox will accept the self-signed certificate.
  • So... Firefox has stopped accepting self-signed certificates, and now I can't watch recorded movies again. Any ideas?
  • Hi Jeff, we're not aware of this change, and in fact I've just tested the latest version of FireFox and it appears to work fine with self-signed certificates. When you first attempt to visit the site it will give you a warning, you click the "I Understand the Risks" link and then the "Add Exception" button and then confirm. You only have to do this once - subsequently FireFox will remember that you have authorised the site.

    Alternatively, it's easy and inexpensive to purchase and install an official SSL certificate for SecuritySpy.
  • I guess I'm just worn out! First it stopped working in Safari, then IOS devices, and now I got the client switched over to Firefox but that has stopped working. Here is the error message when trying to add an exception: http://bit.ly/1zfpkH7
  • Hi Jeff - a quick google search reveals quite a lot of people experiencing this problem with FireFox. Please try this:

    - Go to Preferences -> Advanced -> View Certificates -> Other
    - Delete all the certificates there (you should see at least one for SecuritySpy)
    - Quit and reopen FireFox, and attempt to view the SecuritySpy HTTPS web server

    Does that resolve the issue?

    The problem with Safari and iOS is that they unfortunately don't play movie files from sites with self-signed certificates. The solution for these clients would be to obtain an official certificate (as per my link above).
  • Unfortunately that didn't work. Can't see the remote server at all. I guess I'll have to go the official certificate route.

    I don't really understand why it doesn't work though... I have a Raspberry Pi web server that I can view remotely via a forwarding service called PageKite, and I don't have any certificate installed but it works in Safari and Firefox. I'm not viewing movies with it however, just data.

    I will buy a certificate and let you know how it goes.
  • I was able to visit the site yesterday, and discovered that I made a choice which caused the problems. I had un-checked http: logins, and only had https: logins checked. Checking http: logins again restored functionality to Safari on IOS, which is what my client wanted. I did not buy a SSL cert. I think http: is a good solution for a low tech operation.
    Thanks for your patience!
  • Hi Jeff,

    I can't imagine why that would prevent FireFox from accessing the HTTPS server, in fact I've just done a test here with HTTP turned off and HTTPS turned on, with a self-signed certificate, and FireFox accepts it just fine.

    Anyway, I'm glad to hear everything is working again. If you want to switch back to HTTPS in the future, note that Safari and iOS will need an official (not self-signed) certificate in order to play back movie files (Chrome and FireFox do not have this limitation).

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!