Jovision JVS-N4DL-HC
  • Hi,

    I have a few Jovision cameras that are working with SS using ONVIF. The problem I'm having is that I'll get a green screen randomly every few seconds. I have played around with all the setting and I have stabilized this by setting GOP to 1 in the camera setting. This resolved the green screen issue, the problem now is that I have a lot of noise in the picture. The motion detection indicator is going crazy. I have managed to dial it down the image is poor compared to when GOP was set to 20.

    Do you have any insight as to how I may improve the picture quality.

    I have Vivotek cameras also which are working great, but the Jovision ones are 1/3 the price.

    Thank you in advance.
  • Hi gab, a green screen indicates corruption of the video stream. We have seen this with some cheaper cameras unfortunately. Firstly, check for any firmware updates supplied by the manufacturer, as this may fix the problem.

    Another thing you can try is different Format options in the Video Device Settings window, for example for the ONVIF setting you will be able to choose between TCP or UDP transfer - try them both. Some cameras work better with one; some with the other.

    Also make sure that the network connection from your camera to your computer is fast enough. Ideally you want wired gigabit ethernet. If the camera is connected wirelessly, try to connect it using an ethernet cable to see if this problem goes away.

    One other thing that may help is to reduce the frame rate set in the camera's settings pages (connect to the camera using a web browser to adjust its settings).

    Ideally, for efficient video streams, you want a GOP setting of around 20, however using a GOP length of 1 should in fact work fine. The bad noise could be due to the camera having a fixed bit rate (reducing the GOP length to 1 increases the bit rate, so the camera would have to compensate by reducing the compression quality to maintain its fixed bit rate setting, resulting in compression artifacts which look like bad noise). If the camera allows you to switch between CBR (Constant Bit Rate) and VBR (Variable Bit Rate), select VBR at a medium-high quality. Does this fix it? Or, if it only supports CBR, try increasing the bit rate until you get high-quality video.

    Finally, another idea would be to click the "Get profile list" button in SecuritySpy in the Video Device Settings window - if there is a profile that supplies JPEG video, rather than H.264 video, this may be a good workaround for your problem.

    Hope this helps.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!