Is the server down?
  • Can view local server just fine and web server test works fine but can't access dynamic dns site. Seems the server may be down all together.
  • Hi - unfortunately we have had problems today with all our domains, caused by a DDoS attack on the company that provides our DNS services. We've added additional working DNS servers to the domain to fix this, but this may take up to 24 hours to propagate through the system so during this time some people may find that the service works while others may not.

    Meanwhile, our DNS hosting company is working hard to mitigate the effects of the attack on their primary servers.

    This is also affecting our web site and store unfortunately, as well as email. Sorry for any inconvenience, normal service will be resumed shortly!
  • Okay thanks for the update!
  • Is ViewCam.Me down right now?
  • Warren - as far as I can tell, there may have been some slow updating of IP addresses to the DDNS names yesterday - I observed it taking a bit longer than normal to set the IPs of the names (our DNS server handles updates for many domain names and may have been having a bit of trouble yesterday). However I've just run a few tests now and everything seems to be back to normal - updates are instant. Can you confirm?
  • I couldn't connect to my cameras either locally or externally, but I've partially resolved the problem. When upgrading to OS X Yosemite, the local name of my mac seemed to change from xxxx.home to xxxx.local. Changing the name in Remote Patrol on iPad did the trick. However, no joy with an external connection using the DDNS server. I tried using my current public IP address too (it changes every now and then) but still no joy. I've been using security Spy for a number of years and haven't had any problems accessing the cameras externally, so something must have changed somewhere. All ideas gratefully accepted. Using the latest version 3.4.2
  • OK, update to above - fixed it I think.

    Went to Mac System Preferences > Network and changed Configure IPv4 from 'Using DHCP' to 'Manual' and frightened myself as the Internet connection was lost. I reselected 'Using DHCP' and the computer reconnected with the same IP address as it had before and both the view page and Remote Patrol connected :) Looks like Yosemite just needed a bit of a 'kick'. I'll monitor and see how it goes.
  • Hi Ruyton, for remote viewing to work reliably you will most likely need to set your Mac to use a manual IP address. This is covered in the Setting Up Your Mac section in the SecuritySpy Installation Manual. For manual IP mode to work, you need to specify a valid IP address (outside the range used by your router for DHCP), a subnet mask of, the address of your router (which will be shown in the Network system preference when in DHCP mode), and a DNS server address of (Google's DNS server). This is all covered in the manual page linked to above.

    When in DHCP mode, the address of your Mac can change at any time, which may break the port forwarding rule specified in your router.

  • Is ViewCam.Me down right now? My ddns seems to be down. redirects to
  • There have been no reported problems with the DDNS system, and we can't see any problems with it. itself always redirects to; to access your own SecuritySpy server you'll need to use your DDNS name as set up in the Web preferences in SecuritySpy, in the form, or if you are using 8000 as the external port number in your router's port forwarding settings.
  • Are there issues now? I've been using with my setup for a couple years now, but recently it stopped working. When I hit the "Test" button in Security Spy's web preferences, it says "Unable to set the DDNS name. Error 404 File not found"
  • Hi @jimhead this other forum discussion will explain the problem you are seeing:
  • Hi @benodonohue - isn't meant to point to anything. It's your own address that points to your SecuritySpy server, where xxx is the DDNS name that you specify in SecuritySpy version 4 under Preferences -> SecuritySpy -> Web.
  • Ok, the reason I also suspected that something was down is because I can no longer view my server away from home network. Either on the iOS app or in browser, it was working fine up until 2 days ago..
  • Every time I see posts like this, I quickly check my own viewcam link, and every time it works perfectly for me.
    There's a lot of hops between an end user and viewcam, so possible something in between is blocking access. A simple traceroute might help.
  • Hi @benodonohue - what version of SecuritySpy are you using? If you are using an old 2.x or 3.x version of SecuritySpy, please see this forum discussion:

    If you are using any 4.x version of SecuritySpy that is earlier than the current 4.1.4 release, please upgrade to the latest version (download the latest version of SecuritySpy here).

    If you are using SecuritySpy version 4.1.4, please describe exactly what you are seeing, with any error messages reported by SecuritySpy and/or the web browser that you are attempting to use to access. You should not be having any problems with the service when using SecuritySpy 4.1.4.
  • I'm using latest version.. I just done a factory reset and reboot of my router and everything seems to be working again..
  • OK great to hear that!
  • Mate, I gotta say your response time to questions is second to none, well done & Thanks..
  • One again I'm having issues accessing my view server remotely. It works for a day and then nothing, very frustrating...
  • Here are a few things I can think of that could cause what you are seeing, please check them in turn:

    1. If you have set up port forwarding in your router manually, then your Mac will either need to have a static IP address on your local network, or a DHCP reservation in the router. However if you are using the automatic options "Allow access from the Internet" under Preferences -> Web in SecuritySpy, then you don't need to worry about this.

    2. SecuritySpy needs to be running and your Mac needs to be turned on and awake in order for this all to work. Make sure your Mac is not going to sleep. Turn off the "Allow automatic computer sleep" option under Preferences -> General.

    3. Make sure the Mac running SecuritySpy has a reliable network connection. If it's connected wirelessly, make sure the WiFi signal is strong (though wired Ethernet is always better).

    If the above doesn't help, then the next thing to try is to switch from automatic port forwarding to manual port forwarding - please turn off the "Allow access from the Internet" options in SecuritySpy, and insated follow our Port Forwarding - Manual Setup instructions. This shouldn't normally be necessary, but perhaps there is some strangeness going on with the automatic port forwarding and your router.
  • Some time between a few days ago and last night, my ability to contact the DDNS server has gone away. I've been happily connected for quite a while now, and there have been no changes to my network. I've been out of town, and other processes (such as Indigo) continue to accept connections as expected. I've verified my registration, and all the usual check-off items are not amiss (like the simple list in the reply just above this posting). Anything going on with the reflector? Thanks - WM
  • ...and just to be more specific, the error I get when using the 'test' control is "Unable to set the DDNS name. / Error 404 File not found".
  • Aha. Cancel my request. After installing the latest update, it appears after an automatic restart I was not running the latest update but running a previous version. Fixed now!!!

  • Hi Ben,
    Im using the automatic port forwarding option under Preferences -> Web
    I have unchecked Allow automatic computer sleep
    Im running a wired ethernet connection
    Its very strange because it will work for a day or so and then nothing..
  • There does seem to be something wrong with port 8000 & 8001 as when i do an open port check it is now failing when yesterday it was fine??
    I might have to try the manual port forward option. My ip address is static and i have a DHCP reservation automatically configured in my router so I'm a little confused..
  • OK, if your Mac is already set up with a static IP address that makes it easier. Check what this IP address is under System Preferences -> Network, and confirm there that the "Configure IPv4" option is set to "Manually". Then go ahead and set up port forwarding in your router on ports 8000 and 8001, forwarding to your Mac's IP address. If you need more help with this please let me know the make/model of your router, and your Mac's IP address.
  • So i have gone ahead and configured the IPv4 to manual and on the router port forward'd 8000 & 8001 to my mac ip address. It is now working again mate, You legend.. I still have UPnP & NAT-PMP Enabled on my router though, is that necessary? I will monitor the connection to my server over the next 24 -48hrs and will check back in and let you know if the issue persists. If it goes past the 24hr mark i believe the issue may be resolved.. Thanks
  • Great to hear that! It's fine to leave these features enabled on your router, but I'd advise turning off the "Allow access from the Internet" options in SecuritySpy under Preferences -> Web, so these don't conflict with your manual rules (unlikely to cause problems, but just in case). Please report back after a day or two.

    What is the make/model of your router? It would be useful to know this so that we can advise others experiencing the same problem.
  • I must be missing something because everything is working great except that Security Spy isn't updating the IP I have setup. What would stop that from working? Because every month or two, I have to update it to make it work, but now all I have is a little red light beside the DDNS address.
  • Another interesting thing. I had the name in there, and it was working for awhile, but when I checked it, the last two letters were cut off and there was no way to do it. So it was and now the "es" is cut off, so I changed it to "y". But still nothing. Not sure how I was able to properly enter the full name before, but can't now. But it seems to have no effect on the red light instead of the green light.

    I guess I'll set up a support ticket? Thought I'd get a quick answer here but....
  • Hi @audiobaja firstly make sure you are using the latest version of SecuritySpy. If this doesn't solve the problem, please email us and let us know exactly what happens when you click the "Test" button next to the DDNS feature in SecuritySpy, and please send a screenshot of the Preferences -> Web settings.
  • Hi, Just a follow up from your response on May 16th. As previously stated I went ahead and configured the IPv4 to manual and on the router and port forward'd 8000 & 8001 to my mac ip address. I am happy to say that I have not had an issue since doing this. I will create another post in regards to my overall setup. The router, cameras, switch etc as i think it may assist others..
  • Hi @benodonohue - great to hear that!
  • If I update to newest version from 4.0.1, how is the best way to save existing camera settings? I have multiple Minis & when I did the update it would seem it blew out my camera settings (camera static IP, make & model, etc). I just don't want to make same mistake on the second NVR.
  • Hi @brianchenry - any version of SecuritySpy can read the settings file from any previous version.

    However there may be problems if you have at some time in the past reverted to a previous version of SecuritySpy after using a later one.

    If you are using version 4.0.1, and you are having problems with settings not being retained, try this:

    - Quit SecuritySpy
    - Hold the alt (option) key and click the Go menu in the Finder
    - Select the Library option, and within that window navigate into the Preferences folder
    - Find the "SecuritySpy Preferences vXX" files, where XX is a version number
    - Delete (or move somewhere else) any file with a version number higher than 71
    - Open the latest version of SecuritySpy.

    SecuritySpy v4.0.1 uses the file "SecuritySpy Preferences v71" for its settings, so as long as you don't have any later-version SecuritySpy Preferences files, any newer version of SecuritySpy will be able to find and import these settings.

    If you find that this is not the case, please email us and include this v71 Preferences file, and we will analyse it.
  • Is the server down? I have been operating perfectly for awhile but today can only connect locally.
  • I managed to get it working again by deleting phone settings and re-initializing
  • Me too the viewcam server does not work, I connect only locally.
    I work regularly on another computer connected in the same local network, on macmini it doesn't work (mini 2012 with Mojave) on Macbookpro it works regularly (Macbookpro 2010 with High Sierra).
    Su Mojave worked regularly for about a month then suddenly stopped.
    Sorry my bad English
  • Hi @marmellata, unfortunately this is not enough information to allow us to help you. The DDNS service is working correctly, so the problem must be elsewhere. For help, please email us at and include information on exactly what you are attempting to do, what works and what doesn't work, and please include relevant screenshots (e.g. the Web settings in SecuritySpy).

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!