Can't get Hikvision DS-2CD2032 camera to work
  • Hey guys,

    Been using SecuritySpy for quite some time and just got in these new Hikvision DS-2CD2032 camera's to bring me up to 3 total, but can't get them to work. Here's what I've tried...

    I went in via Safari and changed the IP address to conform to my other camera addressing. I then tried to set the camera up using Dahua Technology, Hikvision, and even Manually as the Device Type, with all using the new IP address. Just like I have done with other cameras on my setup, but no joy. Tried changing the Format to JPEG and even RSTP (video only). The camera is connected via POE to my switch and it's getting power. The IP address comes up in my scan, and I can get to it via the browser (though no video comes through...keeps referencing a Plug-In needed).

    I see all the other posts referencing these cameras, so I know they are working for others. Trying to figure out what I am doing wrong? Your help is appreciated.

    Trey
  • BTW, I just put the version 3.1.3 of SecuritySpy on my MacMini this morning to be sure I had the most current profiles, but still no joy.

    Trey
  • Hi Trey,

    The Hikvision profile in SecuritySpy with the H.264 RTSP format is the way to go for this camera.

    If it's not working, check if you have Perian installed on your computer. If so, you'll have to remove it as it interferes with SecuritySpy's ability to decode the H.264 stream.

    If that's not the problem, please post a recent few lines from the Log file that you'll find in the SecuritySpy folder within your Documents folder, as this should help diagnose the problem.

    Thanks,
    Ben
  • So I saw in one of the other comments about Perian and I had already deleted it. I am getting video on the 2 existing camera's, though the errors below from the log also pop up in Remote Patrol as well, though the video comes through. Double checked settings.

    Log:

    11-27-2013 1113-59: Error communicating with the network device "Front Porch" 3.1.3,70900,800 The operation timed out

    11-27-2013 1113-59: Error communicating with the network device "D-Link DCS-7110" 3.1.3,70900,800 The operation timed out

    11-27-2013 1113-59: Error communicating with the network device "Network camera 1" 3.1.3,70197,-2053 Codec feature unsupported. If you have Perian installed on your computer, uninstalling it should fix this problem.

    I'm assuming from the log I have another Codec item loaded that is interfering? I downloaded the Hikvision Mac Plug-in, but I have not installed it yet.
  • Been looking for hours and can't find anything other than VLC & Handbrake that have anything remotely to do with H.264 (As far as I can tell). I started looking for any "residual Perian" files and this is what I found:
    /Library/Preferences/org.perian.Perian.plist

    I am smart enough to be dangerous, so I did not want to delete without input from Ben.

    I played with the settings and it works on JPEG, though I'm getting the same 1fps issue that someone else reported in another thread.

    So it has to be some issue with the H.264, but I can't determine what's interfering.

    BTW, I am still on OS x 10.6.8, though not sure if that matters.

    Thanks,
    Trey
  • What about Quicktime interfering with H.264? On my DLink DCS-7110 it is capturing in JPEG instead of H.264. When I view the stream in Safari, it flashes a Quicktime logo and then comes up, but if I go into SecuritySpy it will not process it in the format for H.264.
  • Hi Trey, if you are still getting the "Codec feature unsupported" error in SecuritySpy's log, then its still probably some remnant of Perian that is causing this (we haven't seen this particular error caused by anything else). Please check the following folders for anything with Perian in the name and drag it to the trash:

    /Library/QuickTime
    /Library/Components
    /Library/PreferencePanes

    Check for these both in the system Library folder (the one at the root level of your system drive) and also the user Library folder (e.g. /Users/Trey/Library/...). Then restart your computer.

    Alternatively here's another thing to try:

    - Install the latest version of Perian
    - Open the Perian system preference, and click the Remove Perian button
    - Click the Show All button
    - Right-click on Perian and select the Remove option
    - Restart your computer

    Do either of these procedures work?
  • That got it Ben, thanks! Re-Installing and then going through the Remove button procedure took out several of those files I was questioning earlier. I had simply removed the Preference Pane option before.

    You have been the absolute best at taking care of your customers.

    Thanks for the help and have a Happy Thanksgiving.
  • Great to hear that! Thanks for reporting back and Happy Thanksgiving to you too.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!