Hikvision only gets 1fps
  • I have a DS 2CD2032 from Hikvision. SecuritySpy shows it is only getting 1fps, while a Foscam running through the same switch is at 10fps
    configuration settings for Hikvision
    Frame rate = 10
    Resolution=1920x1080
    I frame = 5
    video quality = good
    Encoding=H.264
    Exposure time=1/25
    video std=60hz

    I have tried adjusting the I frame interval and frame rate without success. What else should I try?
  • Additional Information. Both cameras are hard wired. Network activity shows CPU at 12% with minimal use of memory. Tuning off the Foscam drops the network activity without affecting the Hikvision. Changing the Hikvision to 720p still results in 1fps
  • Hi, there are two options for the "Format" Setting in the Video Device Settings window in SecuritySpy for Hikvision cameras: JPEG HTTP and H.264 RTSP. The latter should give you the best performance so please try that.
  • It looks like there is a single option for Hikvision that does not permit a change in format. However, I selected Dahua, another attractively priced camera from the same country, and this worked. Thanks
  • That's a disappointing piece of anecdotal evidence relating to a Hikvision product -- as this model is advertised as having these specs:
    50Hz: 12.5fps (2048 × 1536), 25fps (1920 × 1080), 25fps (1280 × 720)
    60Hz: 15fps (2048 × 1536), 30fps (1920 × 1080), 30fps (1280 × 720)
    http://www.hikvision.com/en/products_show.asp?id=7326

    I was about to purchase the 5MP Hikvision DS-2CD7283F-EZ from a Chinese source. But this post gives me pause.
  • It sounds like the original poster was using an older version of SecuritySpy that didn't have H.264 RTSP enabled for the Hikvision profile. The latest version 3.1.2 of SecuritySpy does have H.264 RTSP enabled for this profile, and therefore should work properly with the camera at the full frame rate.

    The problem was that in JPEG mode the camera is not capable of a high frame rate - which is the only mode available in older versions of SecuritySpy. So I would personally be confident using Hikvision products with SecuritySpy in H.264 mode.
  • Thank you for the input, Ben.
    I'll start a new thread to see if I can get any info here on the 5MP Hikvision DS-2CD7283F-EZ.
  • I have installed the Hikvision DS-2CD2112 and i'm unable to set it to RTSP. only JPEG works and therefore I have also only 1fps. I'm using version 3.1.3.

    is there a setting that I'm missing? camera is able to work with RTSP and port is set to 554?
  • Hi Lucardos, the first thing to check is if you have Perian installed on your computer. You will need to remove this as it interferes with SecuritySpy's ability to decode the H.264 stream. If this doesn't resolve your problem, please email us the Log file that you will find in the SecuritySpy folder within your Documents folder (or copy and paste a few of the latest lines here) and we will look into this further.
  • Hi Ben, thanks for your quick reply. removing Perian solved the problem for me.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!