Foscam FI8905W
  • I just got around to upgrading to 3.1.1 and had this model cameras for a while now but I never got them to work because of what I thought were router issues mostly. I've finally upgraded the router and tried one of these cameras again and the software doesn't see the video. It looks like it sees the camera on the network under Video Device Settings, and the camera seems to work if you log in from a browser to it's IP address. It's just the software that doesn't show the video on the camera's window.
    I ran the latest updates I could find:
    Device Firmware Version 11.25.2.51
    Device Embeded Web UI Version 2.4.20.6

    Any other ideas would be greatly appreciated.
    Thanks!
  • This camera has been tested and confirmed to work with SecuritySpy, so it's hopefully just a minor settings issue that is causing problems here. The setup is as follows:

    In SecuritySpy, open the Video Device Settings window
    Create a new device; enter the camera's IP address
    Select "Foscam JPEG" as the device type
    Enter the camera's username and password
    Make sure the SSL option is off

    If you are still having problems, please email us and include a screenshot of the camera's setup in SecuritySpy along with the Log file that you will find in the SecuritySpy folder within your Documents folder.
  • That was it, I had the wrong device type, how simple it is to overlook the obvious, thanks so much!
  • Great to hear you got it working!

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!