Doorbird issue since firmware upgrade
  • Is anyone else having issues with SS connecting to their Doorbird since the 000121 firmware upgrade?

    I have two Doorbirds on separate SS instances and both have the same issue since they updated their firmware over the weekend. Both SS instances continuously disconnect from the Doorbrid's Onvif stream after exactly 30 seconds. If I connect to the stream via VLC without SS everything is fine, the stream remains open as expected. Everything is fine from the Doorbird app.

    I've tried both the "Doorbird, BirdGuard" and the standard ONVIF profiles. The issue is constant when using either RTSP or RTSP UDP formats. The issue looks very similar to where a keep alive parameter changed in some camera hardware.

    All I get from the error logs is below.

    04/01/2020 13:33:57: Error communicating with the network device "Front Door". 5.0.1,70900,800 Failed to obtain video frame from network device. The operation timed out

    I've raised a support ticket with Doorbird to find out exactly what changed in the firmware update. Going on past experience it's going to take a long time to get this information (if at all).

    Leaving SS continuously attempting connections appears to cause the Doorbird to become non responsive after several hours. A power cycle is required to bring it back online. I believe this to be is a side affect of the underlying issue however.

  • I'm having this same problem w/ my doorbird after 000121 firmware upgrade...
  • This is unfortunate. Yes, it does sound like an issue with the "keep alive" heartbeat messaging. I'm certain that SecuritySpy is sending these heartbeat messages correctly, so it sounds like a firmware issue. Is there any possibility of rolling back to the previous firmware?
  • Unfortunately there is no rollback option. Updates are automatically installed with no opt out option. It is likely that everyone with a Doorbird and SS will soon be affected.

    I’m still waiting on more details from Doorbird support.

    Is there some further troubleshooting we can do given that the stream remains open when viewing from VLC? Somehow it is able to keep it open?
  • I also have a DoorBird (D2100E) that updated to 000121 yesterday and immediately started exhibiting the same problems as noted by @kwijibo007. After the update the camera was completely dead in SS. I then went to the config page and found SS had Auto-Discovered a new modern DoorBird, so I selected that and the camera connected. However, it still drops out after around 30 seconds with the same error as posted by @kwijibo007. Changing to UDP shortened the reconnect time, but didn't fix the main problem.

    Also note DoorBird seems to have now separated their firmware into two releases, high and low end units. The 000121 release seems to be intended for high end devices.
  • Is there any update on this issue? My camera is unusable until this gets fixed.
  • I have now tested with a DoorBird running the latest firmware version, and it does seem that the camera is timing out and disconnecting every 30 seconds, which does indicate a problem with the "keep-alive" mechanism. Unfortunately I have been unable to find a solution so far - no matter what type of "keep-alive" message SecuritySpy sends, or how frequently, the camera is doing the same thing. At this point it looks like a firmware bug, though I can't explain why VLC is apparently unaffected.

    I have contacted DoorBird to ask for assistance and I hope they will reply with the technical information I need. I will post back when there has been some progress.
  • I have heard back from DoorBird already - they are aware of the problem (it's affecting a number of NVRs) and they are investigating. I'm awaiting more information - whether there is anything we can do in SecuritySpy, or whether it will require a firmware update from them.
  • Thanks for your help with this, Ben. Really appreciated.
  • DoorBird support got in touch to let me know that they had pushed the 000122 firmware to my DoorBird and that the issue should be fixed.

    Unfortunately the same problem exists. I’ll update when I have more info.
  • According to DoorBird, firmware 000122 is being rolled out now, and should fix the problem.

    @kwijibo007 - can you verify somehow if your camera is indeed running firmware version 000122? Perhaps is is still on the older version.
  • Ben, my Doorbird is still running 000121 right now, will check again tomorrow.
  • Hi Ben,

    I can confirm that it’s on the new firmware. The DoorBird App shows you the current firmware version.

    I got an email from Doorbird overnight explaining that they had re-pushed the update as it had not applied correctly.

    Unfortunately the issue still persists. Interestingly SS now re-connects much much faster after the 30 second disconnect. Previously I could never get the SS iOS app to show the feed. Now it does (for about 10 seconds each reconnect cycle). So something has changed...

  • Also, I re-tried all the ONVIF TCP/UDP options. No luck.

    The HTTP ONVIF option now connects (for 30 seconds) whereas it never worked at all before.
  • I'm still on 000121 today - guess they are only pushing 122 to specific users & not more broadly.
  • OK so apparently the 000122 DoorBird firmware fixes the problem on their end, but it also shortens the required frequency of these keep-alive messages to 10 seconds, and SecuritySpy isn't sending them fast enough. So in the latest beta version of SecuritySpy (currently 5.2.1b9) we have reduced the time between these message to 5 seconds, which should resolve the problem. Please can you all test this and report back.
  • Hi Ben,

    Thanks for reaching out to DoorBird and working to find a resolution.

    I've not yet installed the 5.2.1b9 beta on my SS instance because I woke up this morning and everything was working. I think DoorBird support have been working on my unit remotelty so I suspect they have changed a setting (probably the timeout value) in their testing. I'll wait to hear back from DoorBird support before proceeding.

    However, on another Security Spy instance (and Doorbird running the 000121 firmware) that I have access to I have installed the 5.2.1b9 beta and it does appear to resolve the issue. I'm remotely located to this instance so I can't properly test. @gauchers, it may be worth testing the beta to see if yours is fixed on the older firmware?

  • Ben:

    Thanks for the update. Unlike @kwijibo007, my camera still did not work after the 000122 upgrade so I tried 5.2.1b9. That did resolve the issues with the DoorBird video.

    However, the beta seems to have broken another camera, an IPD-D53L02 5MP camera. That camera no longer works with H265, only H264. In fact, after installing the beta, the camera did not work at all at first, and only after a profile search did I get it to work with a Zoneway config. Restoring the SecuritySpy preferences file and then switching to H264 got it working again. I was eventually able to connect aw H265, buit is unstable at the highest quality/size settings.

  • Hi @berkinet - the beta doesn't have any other changes related to connecting to IP cameras, so the problem with your IPD-D53L02 camera are most likely a coincidence. When you say it is "unstable" at the highest quality/size settings, what exactly are the symptoms? It's probably best if we try to resolve this with you directly, so that this forum discussion doesn't get too off-topic, so please could you email us and include the log file (File menu in SecuritySpy -> Open Log) as well as a screenshot of this camera's setup in SecuritySpy.
  • I downloaded 5.2.1b9 over the weekend & it has resolved my Doorbird problem. My Doorbird is still on 000121 firmware. Thanks Ben!
  • Update - my doorbird was just upgraded to 000122 firmware & still working great w/ 5.2.1b9
  • Update #2 - my doorbird was updated to 000123 firmware & is having issues again...
  • That's unfortunate, could you please describe exactly what problem you are seeing?

    Is everyone else here seeing the same thing with the 000123 firmware?
  • Ben, same problem as the original post in the thread - can't maintain a connection. -Roger
  • Anyone having issues w/ 000123 firmware?

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!