Hikvision 4MP IR Cube question
  • I recently swapped out a couple of old Foscam cameras for 4MP IR Cube ones from Hikvision. They're recognized in SecuritySpy (5.0), and I can see them when I log in directly via web browser rather than SecuritySpy, but SecuritySpy only shows them briefly on app launch and then consistently gives the error "5.1.0,70902,800 Failed to obtain video frame from network device." I've lowered the frame rate, the I frame number, even the resolution, with no success. I have a 2MP IR Cube that's been working like a champ. Is there something different with the 4MP, some setting somewhere that I should adjust? Thanks in advance for any help.
  • This is a timeout error - so the camera apparently stops responding for some reason.

    When this happens, what will make it start working again? Does quitting and reopening SecuritySpy work? Or do you have to restart the camera?

    Are you using the Hikvision profile or the ONVIF profile in SecuritySpy (under Preferences -> Cameras -> Device)? Try both of these options in case one is more reliable than the other.
  • I have the hikvision cube camera.

    If you're using an ethernet cable - please ignore the rest of this post.

    If you are using wifi - try connecting via ethernet cable to rule out wifi coverage/bandwidth constraints. I run this camera over wifi and get these messages every now and again.

    You could try reducing the bitrate, rather than the other settings.

    I'm running it at 4096Kbps, 2688x1520, Variable bit rate, Highest video quality, 20fps, H264, H264+ OFF, High Profile, 40 Iframe interval, SVC OFF, 50 Smoothing.

    I'm not saying these are the best/correct settings, it's just what I have and works pretty well for me. Even try 1024Kbps as a test, the picture quality will be poor, but it will put less load on your wifi.

  • Thanks for your help! Unfortunately still no luck. I've tried reducing the bitrate and otherwise using the same settings as you have, nicholas, but I still get a Timeout error when the cameras are trying to connect. I'm using the Hikvision profile; when I use ONVIF I get an Unrecognized Request message. When I restart the cameras I do get them to show up, and half the time when I restart SecuritySpy they show up, but then go down a minute later with the Timeout message. The cameras seem to work fine otherwise, I can access them via the web interface and access all admin functions. They do seem to show up a bit more often on restarting SecuritySpy with the reduced bitrate (down to 256, as low as it'll go) so that does lead me to believe that there's a wifi issue. Thanks again.
  • To check whether it's a WiFi issue, connect the camera via Ethernet cable to your network (i.e. to your switch or router) and see if you still get the connection problems. This will help us to narrow down where the problem might lie. Ideally, you Mac should also be connected via Ethernet in the same way - is it?
  • It's definitely a WiFi issue. But here's an interesting thing. Setting the Bitrate Type to Constant improved both connectivity and image quality via WiFi.

  • Slightly off topic. I just got the IR Cube and I can't view it on a web browser, I see a flash of something than a question mark. It works fine from SecuritySpy.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!