SecuritySpy 4.2.9 and Mojave 10.14.2
  • I have recently been getting a pop-up window in SecuritySpy (version 4.2.9) compatibility with my iMac (2017, 3.4 Ghz, 32 GB RAM, macOS 10.14.2). Is there an issue on my end or will a newer SecuritySpy version correct this pop-up? The message says the following:

    "SecuritySpy" is not optimized for your Mac and needs to be updated.

    This software will not work with future versions of macOS and needs to be updated to improve compatibility. Contact the developer for more information.


  • Same here...
  • SecuritySpy itself is a 64-bit application, and does not need to be updated/optimised for current and future macOS versions.

    However, SecuritySpy does currently contain a tiny 32-bit executable tool in its bundle which is used infrequently for a specific purpose, and it is this tool appears to be triggering this message. We have already come up with a workaround for this, which will be in the next update (out soon).
  • I just had it pop up for me last night. Good to know this is known!

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!