Strange App access problem after latest upgrade - solved
  • Could not get SecuritySpy app to work after latest upgrade, kept saying could not connect to server. Worked fine from my phone connected to the internal WiFi but not on 4G ?

    I tried every thing and eventually tracked it down to the preferences page were it said

    Bonjour/Server name: SecuritySpy

    My firewall rule had "securityspy" in it i.e. no upper case S and S. When I changed the two S to lower case it worked. Maybe this a default in which case I should probably change my firewall rule to SecuritySpy with upper case S ?
  • Completely confused its stopped working again ?
  • The firewall rule is independent of the Bonjour name - changes or discrepancies in one won't affect the other.

    Did you create the firewall rule manually, or was it automatically created by SecuritySpy?

    When you attempt to connect from your iOS device, your Mac must be awake and running SecuritySpy at the time - is this the case?

    If you are still having problems, it's probably best if we can work with you directly to resolve them, so please email us and we'll see if we can get this fixed for you. Please include screenshots of the Web settings in SecuritySpy, your firewall rules, and any relevant settings you have changed in your router.
  • Hi Ben thanks for your reply :)

    Are you saying that the latest version of security spy creates the firewall rule for me ?

    I have always done that myself before when it worked.

    Tried removing the firewall rules but still does not work.

    The Mac is awake and it connects perfectly from my iPhone when I use WiFi (on my own LAN) but won't connect when on 4G/away from my LAN.

    This really has me stumped :(
  • SecuritySpy doesn't create the Mac firewall rule (the one that you set up in System Preferences), however it does automatically set up port forwarding in your router. In some routers, the port forwarding settings are combined with the firewall settings. So it wasn't clear in your first message which firewall you were referring to - the one on your Mac or the one in your router.

    If you send us an email with all the screenshots I requested we'll take it from there. There's usually a simple explanation as to why this isn't working, however it is a bit strange that it worked and then stopped working - normally once it's set up and working once, it will keep working thereafter.
  • Ok first the good news, it's fixed!

    I spent nearly two days fiddling with every setting over and over. Its amazing how you end up in one train of thought, only to find out that the problem lies elsewhere.

    At least I have learnt something about UPnP. I got an email back from your helpdesk from Rod (very helpful) which pointed me to all sorts of possible causes and of course the specifi parts of manual which I had read. He mentioned UPnP which set me off in the right direction :)

    I was convinced the problem lay in the port forwarding and in a way it did when after constantly setting and resetting them, made no effect.

    What I didn't realise/understand was UPnP which now I do.

    My SKY Router/Hub (UK) does in fact support UPnP which I didn't know/understand and was in fact switched on. When I went into the setting there was a UPnP Portmap Table and right there was my SecuritySpy server IP, with ports listed as Int Port 0 and Ext Port 0. I knew this did not look right as I had manually set them to 8000:8001!

    As soon as I switched UPnP off, it worked perfectly!!

    I think it and the auto setup in SecuritySpy where conflicting. I must have made some changes to the auto port setup when I upgraded and it initially did not work, which somehow then got my hub into a mess.

    Its good I found this setting as I also noticed that two of my Hikvision cameras where in there with all sorts of ports opened up!

    Recently both of these cameras where broken into and the firmware exploited to change the password. I have since upgraded the firmware exploit and of course with UPnP turned off, they are no longer accessable.

    Now I understand UPnP, I am sticking with what I consider the more secure option of not using UPnP and setting up all my ports manually. I think sometimes, although automation makes things easier, it is not always the most secure option.

    Such a frustrating couple of days but I have learnt lots!!

    SecuritySpy is such great software which I have used for a few years now. I upgraded it to four cameras and the 64bit version last year after I finally managed to upgrade my Mac O/S. Since then it has pretty much run continually, without fault, for months and months with my four cameras and an old (2009) Mac Mini :)

    Thanks again for the excellent software and of course, very importantly, great software support!
  • Great to hear you worked this out.

    UPnP works in the vast majority of cases to automatically set up port forwarding in routers, however it seems there was some problem in your case. It's the first time we've heard of this particular problem with the ports being set to zeros instead of their actual values, so I'm not immediately sure what could have gone wrong here.

    Yes, UPnP can be somewhat of a security risk as it does allow devices to make themselves accessible from the Internet automatically, and unfortunately many IP cameras have this feature turned on by default, which really shouldn't be the case.

    Thanks for your kind words about SecuritySpy - glad you like the software!
  • Thanks, yes I have now turned UPnP off on all my cameras.

    Rod also replied about setting up the Cameras for SSL access and creating a secure admin account for the SecuritySpy server.

    He also recommended turning off any remote access to my router, but I had that set anyway :)

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!