Error 302 Failed to obtain video frame from network device
  • I just migrated to a new server. Clean install of 10.13.2, fresh copy of SS 4.2.3. Copied over my prefs file from old machine. Same version of SS, but old Machine was running OS X 10.9.5. All settings came over, but 11 of my 23 cameras show Offline in Camera info. Log shows the following for each camera:

    01/24/2018 12:52:53: Error communicating with the network device "camera name". 4.2.3,70280,302 Failed to obtain video frame from network device.

    Everything was working fine on the old box. Any ideas? Help, please. Thank you.
  • Actually.. Never mind. The problem seemed to have fixed itself after about a half hour. I was just impatient it seems.
  • Instead of the video stream, it appears that the camera was replying to SecuritySpy's request with an HTTP/RTSP result code of 302, which means "this resource has temporarily moved". It's strange that it would do this, then go back to normal after a short time; this is not something I've seen before. If this happens again, try a restart of the camera and check if there is any updated firmware for the camera available from the manufacturer.
  • There is still something screwy going on. When I try to add cameras from another SecuritySpy client for remote viewing they all show as offline in camera info window and Connection closed in all cameras view. All cameras give the following error in the log:

    01/25/2018 11:58:07: Error communicating with the network device "camera name". 4.2.3,89900,8800 Failed to obtain video frame from network device. Connection closed by the other side.

    I've tried this from multiple client Macs, restarted SS on the server, etc. Any ideas? Thank you.

    For the record I've seen reference to the cameras on a client Mac have to be set to "passive mode." I assume that just means to not have them set to motion capture or continuous capture, but I think I would still be getting a trial demo error, and I get the above errors.
  • Or when I try to add the cameras, it will say connection closed by the other side. And this is all cameras.
  • This sounds like a known bug in SecuritySpy 4.2.3, whereby when you attempt to simultaneously view many cameras at the same time it can trigger SecuritySpy anti-hacking measures which will block the client for a short time. This is fixed in the latest beta version of SecuritySpy (currently 4.2.4b3) and will shortly be released as a full update.
  • I'm running the beta version and it seems to have fixed the problem. I'll update as soon as the new release comes out. Thank you.
  • Still seeing this error consistently throughout the day on two of my cameras. Admittedly they are cheap cameras, Trendnet TV-IP551WI, but I've never had a problem with them until SS 4.2.3. I have them set at 7 FPS, 640x480 at medium quality. If I go in to SS and do anything and save preferences they come back up. Idk, maybe I shouldn't use such cheap cameras, but since these are wireless they are quite handy to drop in places quickly when I need to.

    02/01/2018 04:34:14: Error communicating with the network device "Gym Concession". 4.2.4b3,70280,302 Failed to obtain video frame from network device.
  • Can you tell me what "Profile" and "Format" settings you are using for this camera under Preferences -> Cameras -> Device? If there are multiple different Format settings available, please try them in turn to check if there is a format that does not exhibit this problem.

    Also, make sure to check that your cameras are running the latest firmware. You can find this on the TRENDnet TV-IP551WI product page.
  • Profile is Trendnet TV-IP501, TV IP551, TV-IP751.
    format is JPEG HTTP Audio and video (grayed out so this is the only option)
    I've also tried ONVIF
    Cameras are running the latest firmware.
    Cameras are set on 640 by 480 at 7 FPS, but I've tried 5, 15, and auto FPS. Not may options on the camera.

    Anything I've missed, Ben? thanks so much. Like I said these used to work without fail. both are on Ethernet. But I've tried them as wifi too. Same thing. 302 error.
  • Hi @mgisd - would it be possible for you to put one of your cameras online temporarily so that we can connect to it from here and do some testing? To do this you will have to set up the port forwarding settings on your router to forward incoming connections to the camera on port 80, and email us your public IP address (or DDNS name, which can be set up in SecuritySpy's Web Server Setup window). Please send a link to this forum discussion in your email so we know what you're emailing about.
  • Thanks, Ben. Again, I can't explain it, for the last few days all cameras have been online without a problem. We are a school so I have a content filter in place (a very pesky content filter). On a hunch I put the server's IP address in the ignore list to bypass the content filter. That may have fixed my problem.
  • Yes it could be this content filter - 302 is an HTTP redirection, so perhaps this was the content filter attempting to redirect the client to a page explaining that the content has been blocked.

    For speed and reliability, you don't want any kind of filter/firewall between the cameras and SecuritySpy - I don't know your network setup, but if you can bypass this for the cameras I think it would be a good idea.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!