FI9828P V2 and Preset PTZ
  • One of my cameras is a Foscam FI9828P V2 with the latest firmware. It works with SecuritySpy and can be controlled via manual PTZ controls. The problem is SecuritySpy cannot seem to get it to go to any presets.

    I can get the presets to work via the browser interface but I suspect the camera is not storing presets in a standard fashion. The camera is only detected as an ONVIF camera and not as a Foscam - and when selecting as a Foscam even fewer functions work properly.

    Any advice on how to get Preset PTZ to work?
  • When creating the preset positions, make sure to do this in SecuritySpy (alt-click on a preset number) rather than in the camera's web interface. SecuritySpy will only be able to recall presets that it has set itself.

    Also, SecuritySpy has preset commands built into its "Foscam H.264" profile - have you tried this one in addition to ONVIF?
  • Ahhh. Interesting and good to know. I’ll give the ALT+CLICK a try. I tried the Foscam h.264 as well without any difference.

    I set all my Amcrest defaults via each camera’s web interface and they worked just fine when clicking on the respective PTZ positions in SecuritySpy.
  • Hmmm.... I've tried ALT-CLICK from both SecuritySpy (within PTZ controls on the camera) and within the web interface but neither seem to record the preset. Also tried from Windows via web UI as well as CMD-CLICK and CTRL-CLICK to no avail.

    Could I be missing something?
  • Disregard. I think I found the issue. There was a firmware update it was missing. After applying that, it seems to have resolved the issue.
  • I have a new Amcrest. The Presets don't survive a restart of the app.

    That is also the situation with my TrendNet that I am getting rid of.

    What to do to get the Presets that I set within SecuritySpy to stick?

    Amcrest IP2M-841; SecuritySpy 4.2.1; Profile = ONVIF


Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!