Unable to set the DDNS name. (Error -9836)
  • Hi,

    I'm getting an error when trying to set the Dynamic DNS name in the preferences.
    Error -9836

    SecuritySpy version 4.2 on Mac OS X 10.8.5

    How can i fix this?
  • Hi, this is an unusual problem that isn't being reported by any other user at this time. It indicates a problem negotiating a secure (SSL) connection to our servers.

    Please could you restart your Mac and try again - does this fix it?
  • I have this same issue. Rebooted Mac, modem/router, and cameras. I’m running OS 10.8.5. I couldn’t get the 64bit version to work. It kept crashing so I installed the 32 bit version and it seems to work fine. Cameras are able to be viewed through the Mac or via the Control4 app via WiFi.

    I finally updated SS to the latest version so I could access my cameras remotely again. But can’t connect to the DDNS server. Is there a specific name I need to input? The old settings transferred to the new software but it still didn’t work, then I did attempt to change the name but had no success there either.

    Help to resolve this issue would be greatly appreciated.
  • OK we have got to the bottom of this issue now.

    The security of our servers has recently been increased, a process that included disabling old and insecure SSL cyphers and protocols that would leave our servers open to attack by hackers. This unfortunately means that the built-in SSL capabilities of older macOS systems (specifically versions 10.8.x and below) are not up to the task of making secure connections to our servers. This is affecting the ability to get updated files, send push notifications, set the DDNS name and send emails.

    So, we have come up with a solution which is to bypass the macOS system's SSL capabilities and implement SSL communication directly in SecuritySpy itself, using the latest OpenSSL libraries. This way, we can continue to support these older systems with no compromise in security.

    This functionality has been added to the latest beta version of SecuritySpy (currently 4.2.1b10). Everything should now work, so please test this version and report back.
  • I have downloaded the new update and installed. I now get a green light on the Dynamic DNS name test. I can view my cameras via WiFi but still can not view remotely through the app. Multiple devices and reinstall/reboots were attempted. The app does recognize SS in WiFi but gives me “Unable to connect to server” error when I’m on a cellular signal. I also tried entering in the server info manually with the same results.

    I can view my camera remotely from Safari, however with one caveat. If I select more than one camera for multiple viewing all images remain blank.

    Hopefully we’re close to solving the issue.

  • I hit upon this DDNS issue today too with OS X Lion 10.7. Glad it is being investigated and possibly solved.

    I couldn't load www.bensoftware.com from the same machine and I suspected it was due to SSL and this Safari not being able to support newer ciphers.
  • Hi @samuellemons - the issue that has been fixed is specifically the setting of the DDNS name on these older systems. However it sounds like you have a more general problem with remote viewing, which could be down to your Internet connection, router, client setup etc. Please could you email us and include screenshots of your setup (including SecuritySpy's Web settings, and any relevant settings pages in your router) and we will help you with this directly.

    @gurth - yes, this is the same reason why Safari on macOS 10.7 can no longer connect securely to our site. However you can still access the non-encrypted version of our site in Safari at http://bensoftware.com, or you can use Google Chrome to access the secure version at https://bensoftware.com.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!