• Any future support for Amcrest? At one of our facilities we use a PC with Blue Iris, which supports our Amcrest system. Our main facility we use SecuritySpy. Did not see Amcrest in the list for Cameras. :(

  • These are very new so we haven't had a chance to test them yet, but there is some mention of ONVIF support on their web site, so it will hopefully be a simply case of using the ONVIF profile built into SecuritySpy. Also, some of their cameras look like rebrands of other manufacturers' cameras (e.g. the Amcrest AMC1080DM36-W looks very much like the Dahua HAC-HDW1200M, so it may work using the Dahua profile providing the firmware isn't too different). Do you have one of these cameras already?
  • Also, Amcrest seems connected to Foscam, so it's likely that some of their cameras are Foscam rebrands, or at least contain some shared hardware or software, so the Foscam H.264 profile in SecuritySpy is another one to try with these cameras.
  • Thanks for the response. Actually, I am not sure of the exact model of the Cameras. We picked up a 4 Camera/DVR system for outdoors from Amazon after reading a few reviews on decent low priced outdoor systems. Once we got it setup, we tried to add it to our BlueIris system and it listed the model name in the camera setup selection and automatically added our cameras. Then when we went to our SecuritySpy system we didn't see anything for Amcrest. Here is a link to what we have.

  • I'd recommend first using our Network Device Finder app to locate the cameras' IP addresses, then attempting to set one of them up in SecuritySpy - first try the "Foscam H.264" profile (try both 554 and 88 as the RTSP port), and if that doesn't work try the ONVIF profile.

    Any luck?
  • The only ip address it comes up with is the one of the DVR. Thats the IP I use with Blue Iris. Then, in Blue Iris there is a section to select the camera number (1 thru 4) to setup and show all my cameras.
  • On closer inspection, the cameras are actually analog cameras, rather than IP cameras. So you'll need to point SecuritySpy to the DVR to get the video. Please try this:

    - In the Video Device Settings window in SecuritySpy create a new device
    - Set the device type to Manual
    - Enter the DVR's IP address, username and password
    - Select RTSP as the Format
    - Enter cam/realmonitor?channel=1&subtype=0 as the Request

    To add the additional channels, repeat the above steps, and change the channel setting in the request to 2, 3 and 4 respecctively.
  • Nope no luck. :(
  • I was just able to add an Amcrest IP2M-841W 1080P camera to SecuritySpy. I used the ONVIF profile and RTSP port 554. I did purchase this camera through Foscam via Amazon. I can see the camera in SecuritySpy and but the controls are not working well. For example, hitting the pan left button causes the camera to pan left until it reaches it's boundary and then it stops. Same behavior for all directions and zoom in/out. Another issue is that the presets created through the Amcrest web UI are not recognized in the SecuritySpy UI.
  • Based on another post regarding trouble with Pan/Tilt not stopping I changed the profile to 'Dahua Technology' and now the Pan/Tilt and Presets work well. However, the zoom in/out still goes to the boundary on a single click.
  • Hi @lewisba, thanks for the information. We'll check the Dahua profile and see if there is anything we can do about the zooming. It's possible that the camera needs a different "stop" command for zomming vs. panning/tilting (most cameras don't, but a minority do).
  • Here is the latest on my Amcrest DVR. I setup like you said above and log shows this:

    "01-08-2016 1510-29: Error communicating with the network device "Network camera" 3.4.8,80210,404 File not found"

    The DVR uses Media Port 9000, HTTP Port 8888, and RTSP Port 554. I have set SS with those HTTP/RTSP ports.


  • Hi Steve,

    The 404 message means that the DVR didn't understand the request string. Are you sure that you are setting the "Format" setting to RTSP, in the Video Device Settings window in SecuritySpy, and not HTTP?

    You could try this request string: cam/realmonitor?channel=1&subtype=1 (the subtype value is different). This is a request string directly from Amcrest's own web site.

    Try also the "RTSP-over-HTTP" Format option in the Video Device Settings window, with an HTTP port value of both 80 and 8888.

    If none of these work, then you might be out of luck I'm afraid. The only thing left would be to contact Amcrest directly and ask if your device can send an RTSP stream to third-party applications such as SecuritySpy, and ask exactly what the RTSP string is for your device.
  • Ah a good start! I got it to come up with camera 1 by just using HTTP port 8888 and RTSP port 554 and leaving the request area blank. Format is the RTSP TCP. Now just need to find a way to access camera 2,3 and 4 lol.
  • Good to hear you managed to get one camera working - that's progress!

    Usually, multi-input devices use different request strings over the same RTSP port for the different inputs, but we have also seen devices that use different ports for each input instead with no request string, so check the device's settings and manual for any indication that this might be the case, and if so what these additional RTSP ports numbers are. Otherwise, it might be a case of asking Amcrest for the correct request strings.
  • I talked with the people at Amcrest at CES - they had a booth. Their cameras look like Foscam, but are MUCH MUCH better. The software is really nice - not quite as complete as the Axis, but pretty close. The image quality is sharp, and the pricepoint is good. They said they re-wrote the firmware from scratch, and while the hardware looks like Foscam, it's a higher quality build overall. Amcrest also confusingly is the biggest (only?) distributor for Foscam in the US. I went to the Foscam booth as well and berated them for their terrible software design, and they at least were interested in hearing my issues but I just gave up on their stuff because it's so bad I really don't know where to start. Even trying to communicate with their help department is an exercise in futility.

    I'm hoping that the Amcrest can be a good replacement for Foscam and which has well-written firmware at a lower price than the Axis, which has been my go-to brand for many years. From what I saw in the booth, I like Amcrest's product line up and they seem to "get it".

    However, as I note in another thread ( the ONVIF commands sent by SecuritySpy for "stop moving" don't seem to be recognized. I tried setting to Dahua, but no luck - authentication problems.

    Ben, I can put one of these somewhere where you can take a swing at it.

  • Hi @jtodd, sorry you've had this problem with your Amcrest. As per my response in the other thread, I've emailed you a link to an updated beta version for you to test, so please let me know if there is any improvement. If not, then it would really help if you can put the camera online, this should enable us work out what is going wrong.
  • Hi @sproctor @sproctor61 - I've heard back from Amcrest with some information about your NVR. Please try these settings:

    - Set the device type to Manual
    - Enter the NVR's IP address, username and password
    - Select RTSP as the Format
    - For the Request, use h264Preview_01_main for the first channel, h264Preview_02_main for the second channel etc.

    Does this work?
  • Thanks Ben, I will give this a try this evening. I also have another question for ya. This is kinda related but not really lol. On my SS Server I have other cams aside from the DVR. Most are Foscom C1's. With the Blue Iris iPhone app (when running the BI server of course), I have the ability to toggle on and off the night vision. I noticed I can't do that with SS. I assume its the iPhone app not SS itself no? I am currently using Remote Patrol and SpyGlass for accessing my SS video from my iPhone.

    Thanks, Steve
  • Hi Steve,

    SecuritySpy currently doesn't have a feature for controlling the IR light in the C1, though it should be easy to implement (we put these kinds of things in the contextual menu you get when right-clicking on a particular camera feed). However there is no facility in Remote Patrol or Spyglass to access such a setting at this time unfortunately, so it would be up to the developers of these apps to implement it.
  • Thanks for the reply Ben. Hopefully we will see this feature in the apps and SS in the future. On a side note, the info you gave me above for the Amcrest worked perfectly. Thank you for contacting them and looking this up for me.

  • Hi Steve, great to hear you've had success with the Amcrest! Can you confirm that you have all 4 channels from the Amcrest NVR streaming to SecuritySpy using the RTSP requests h264Preview_01_main, h264Preview_02_main, h264Preview_03_main and h264Preview_04_main?
  • Yep all for work using the above settings.
  • Update: The Amcrest camera I have (IP2M-841B) now works well with SS 3.4.9 with the "Amcrest" profile. Thanks, Ben!
  • jtodd, is the PTZ functionality working for you? I can connect fine with the same cameras using the "Amcrest" profile but PTZ doesn't seem to be working (I have two cameras, neither works).
  • jstewart30: Yes, the PTZ is working for the model I have. Sorry, I don't have any other models to test with.
  • I have 3 Amcrest IP2M-841B installed and all function work (PTZ, zoom, presets, enable/disable active mode, etc.) except 2-way talk. Hopefully 4.0 will bring 2-way talk.
  • That's odd...I don't understand why my PTZ functions don't work with either IP2M-841B I'm using. I'm using SS version 3.4.10, device type "Amcrest", HTTP port blank, RTSP port forwarded to the RTSP port set in the Amcrest device, input number 1, no recompression. Video displays fine but neither responds to P/T requests. I have other Foscams on this setup and they work just fine. Any ideas?
  • Hi @jstewart30 - have you entered the admin username and password into SecuritySpy for your camera? Sometimes cameras allow viewing with a lower level of authentication, but require admin login details to allow PTZ control.
  • Hi @Ben, thanks for the suggestion. I'm already using the admin login. Here's a log entry that may help?

    06-17-2016 1444-32: Error sending PTZ command for camera "xyz" 3.4.10,4410,32 Broken pipe (EPIPE)
  • I realize this thread has been inactive for a while, but it pops right up in Google. On my situation, I created a second user, started with full admin capabilities and selectively took away capabilities leaving PTZ and Live checked.

    One question I still have though now that PTZ works for Amcrests on the desktop SS (version 4.2.6), is that capability built in somewhere into the Security Spy app? That's where PTZ would really come in handy....
  • Whoops just found the app manual. I’ll try that...
  • Hmmm. All I see is Enable notifications and Hide in Multiplex when I follow the manual. PT presets work now on the server...! hopefully I’m missing something in the iOS app? Would be sad not to be able to angle in on the pets...
  • Hi @msknird PTZ control definitely is a feature of the SecuritySpy iOS app. You are looking in the right place, so if you don't see the "Control PTZ" option in that menu you describe (the one with the "Enable Notifications" and "Hide in Multiplex" options), the most likely explanation is that the user account does not have permission to control PTZ on the server. So could you please double-check the permissions for the web account on the server under Preferences -> Web in SecuritySpy.
  • That was it!! Thanks Ben, this is great!
  • Installed an Amcrest IP4M-1026 and having an impossible time maintaining a full-time video stream... (IP2M-841 and two other cameras work just fine...)

    I've tried different resolutions, streams, profiles, formats, wifi access points, locations, settings - both in the camera settings and SS, etc. all to no avail.

    Profiles recommended and alas, tried include:
    Amcrest, RTSP
    Dahua, RTSP
    Q-See, RTSP
    etc., etc...

    I have no trouble accessing the camera's IP/webpage (so long as I first log out of SecuritySpy, for some reason...), so connectivity, in theory, is not the problem.

    Is there some magic combo of settings for this 4M model that work, permanently?

    Desperate but not serious . . .
  • Hi @rintintin without knowing the example symptoms and error messages I can only give you general advice, which is as follows:

    - The Amcrest profile with RTSP format is the correct one to use for your camera.

    - Make sure to install the latest firmware on your Amcrest camera.

    - This is an outdoor camera with WiFi. However, we would strongly recommend connecting all cameras - especially outdoor cameras - by wired Ethernet. When installing cameras outside, they are generally further from WiFi access points, and are on the other side of comparatively thick walls, which often results in inadequate WiFi signals and therefore unstable connections.

    - Try reducing the camera's frame rate (e.g. to 5-10fps). If the network is not fast enough to cope with the video stream at the highest frame rate, then perhaps it will be adequate to transmit a lower frame rate.

    Hope this helps.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!